为什么我下载南川三代的指标编译不通过?
2017-01-04 11:52:00   来源:股票壹网   评论:0 点击:

为什么我下载南川三代的指标编译不通过? @胡萝卜i 木子11:="NCFSYY0 MACS DAY"; HHHH:="MKJS HHHH DAY"; 没有NCFSYY0 和MKJS这两条引用公式!!!--问原作者拿全套公式, 然后再来这里分享……胡萝卜i:
  为什么我下载南川三代的指标编译不通过?
@胡萝卜i

木子11:="NCFSYY0.MACS#DAY";

HHHH:="MKJS.HHHH#DAY";


没有NCFSYY0   和MKJS  这两条引用公式!!!--问原作者拿全套公式, 然后再来这里分享……
 胡萝卜i:   2017-1-4 11:52
   大家帮忙看看哪里不对?

   

{南川三代分时E}{原打开密码:无密码}
{技术指标} {大势型} {主图叠加}
{公式描述: 0726优化版 }
{参数填入: { TT2:(930,1500,1000);  }

STICKLINE(1,HIGH,LOW,2,0),COLORBLACK;
木子1:=(BARSLAST(((HOUR = 9) AND (MINUTE = 31))) + 1);
木子2:=((AMOUNT / VOL) / 100);
木子3:=(SUM((CLOSE * VOL),0) / SUM(VOL,0));
木子4:=(((SETCODE = 0) OR (SETCODE = 1)) AND (CLOSE < 500));
HHH:IF(((SETCODE < 2) AND (CONST(BARSSINCE(CLOSE)) < 241)),CONST(IF((TIME < TT2),HHV(CLOSE,0),SUM((IF((TIME = TT2),1,0) * HHV(CLOSE,0)),0))),DRAWNULL),DOTLINE,COLORFF0000;
LLL:IF(((SETCODE < 2) AND (CONST(BARSSINCE(CLOSE)) < 241)),CONST(IF((TIME < TT2),HHV(CLOSE,0),SUM((IF((TIME = TT2),1,0) * LLV(CLOSE,0)),0))),DRAWNULL),DOTLINE,COLORFF0000;
HHH2:IF((((SETCODE < 2) AND (CONST(BARSSINCE(CLOSE)) < 241)) AND (TIME < (TT2 + 1))),HHH,DRAWNULL),LINETHICK3,COLORFF0000;
LLL2:IF((((SETCODE < 2) AND (CONST(BARSSINCE(CLOSE)) < 241)) AND (TIME < (TT2 + 1))),LLL,DRAWNULL),LINETHICK3,COLORFF0000;
STICKLINE(((TIME = 931) OR (TIME = TT2)),HHH,LLL,1,0),COLORFF0000;
均价:=IF(木子4,木子2,木子3),COLORRED;
木子11:="NCFSYY0.MACS#DAY";
木子12:=(木子11 * 1.3);
DRAWNUMBER_FIX(1,1,1,1,木子11);
DRAWNUMBER_FIX(1,1,0,1,木子11);
木子15:=((CLOSE > REF(CLOSE,1)) AND ((CLOSE / 均价) > (1 + (木子11 / 100))));
木子16:=((CLOSE < REF(CLOSE,1)) AND ((CLOSE / 均价) < (1 - (木子11 / 100))));
HH1:((REF(SUM(木子15,0),1) = 0) AND (SUM(木子15,0) = 1)),NODRAW;
LL1:((REF(SUM(木子16,0),1) = 0) AND (SUM(木子16,0) = 1)),NODRAW;
木子19:=(SUM(HH1,0) * CROSS(COUNT((CLOSE < REF(CLOSE,1)),BARSLAST(HH1)),0.5));
木子20:=(SUM(LL1,0) * CROSS(COUNT((CLOSE > REF(CLOSE,1)),BARSLAST(LL1)),0.5));
CS1:CONST(SUM(IF(木子19,REF(CLOSE,1),DRAWNULL),0)),LINETHICK2,COLORGREEN;
CB1:CONST(SUM(IF(木子20,REF(CLOSE,1),DRAWNULL),0)),LINETHICK2,COLORMAGENTA;
HH2:CROSS(SUM((木子15 AND (CLOSE > (CS1 * (1 + (木子12 / 100))))),0),0.5),NODRAW;
LL2:CROSS(SUM((木子16 AND (CLOSE < (CB1 * (1 - (木子12 / 100))))),0),0.5),NODRAW;
木子25:=(SUM(HH2,0) * CROSS(COUNT((CLOSE < REF(CLOSE,1)),BARSLAST(HH2)),0.5));
木子26:=(SUM(LL2,0) * CROSS(COUNT((CLOSE > REF(CLOSE,1)),BARSLAST(LL2)),0.5));
CS2:CONST(SUM(IF(木子25,REF(CLOSE,1),DRAWNULL),0)),COLORGREEN;
CB2:CONST(SUM(IF(木子26,REF(CLOSE,1),DRAWNULL),0)),COLORMAGENTA;
DRAWICON((HH1 OR HH2),(CLOSE * 1.001),39);
DRAWICON((LL1 OR LL2),(CLOSE * 0.999),38);
DRAWICON((木子20 OR 木子26),(REF(CLOSE,1) * 0.999),7);
DRAWICON((木子19 OR 木子25),(REF(CLOSE,1) * 1.001),8);
价位:=CLOSE,LINETHICK4,COLORWHITE;

{参数精灵: 请设置计算参数:
TT2: PARAM#0 (930.00--1500.00) }

{-----------------------------------};

DD1:=1;
成交额:=V*C/100,NODRAW;{万元}
A20:=SUM((IF(((成交额/8>18) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A30:=SUM((IF(((成交额/8>18) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A60:=(A20+A30);
AAA30:=STRCAT(STRCAT('机构净',CON2STR((100*(A20-A30))/A60,0)),'%');
DRAWTEXT_FIX(DD1=1,0,0.05,0,AAA30),COLORLIRED;



现价:=C,COLORWHITE,LINETHICK1;
量价:=(VOL/CLOSE)/3;
A2:=SUM((IF(((量价>0.20) AND (CLOSE>(REF(CLOSE,1)))),量价,0)),0);
A3:=SUM((IF(((量价>0.20) AND (CLOSE<(REF(CLOSE,1)))),量价,0)),0);
A6:=A2+A3;比:=A2/A3;
AAA3:=STRCAT(STRCAT('差= ',CON2STR((100*(A2-A3))/A6,0)),'%');
DRAWTEXT_FIX(DD1=1,0,0.01,0,AAA3),COLORYELLOW;
DRAWTEXT_FIX(比>2,0,0.40,0,'预'),COLORLIRED;
DRAWTEXT_FIX(比>2,0,0.48,0,'涨'),COLORMAGENTA;
DRAWTEXT_FIX(比>2,0,0.56,0,'停'),COLORRED;
中期线:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4)+100;
IF((比>1.1 AND 中期线<5),C,DRAWNULL),COLORRED,LINETHICK3;
IF((比<1.1 AND 中期线>98.0),C,DRAWNULL),COLORGREEN,LINETHICK3;
均价1:=SUM(C*V,240)/SUM(V,240),COLORYELLOW;
TT:=BARSCOUNT(C);均:=MA(C,TT);
上均线:=均+2*STD(C,3);下均线:=均-2*STD(C,3);
TT1:=SUM(V*C,0)/SUM(V,0);
TT2:=TT1>C AND C<REF(C,1) AND REF(C,1)<REF(C,2) AND REF(V,1)>REF(HHV(V,25),2) AND REF(COUNT(V=HHV(V,10),3)>=1,1);
TT3:=TT1<C AND C<REF(C,1) AND REF(C,1)>REF(C,2) AND REF(V,1)>REF(HHV(V,99),2) AND V/REF(V,1)>=0.5;


V1:=MA(V,1);
C1:=MA(C,1);
H1:=C1>REF(C1,1) AND V1<REF(V1,1)  AND C/均价1>(1+0.001);
H2:=C1>REF(C1,1) AND V1<REF(V1,1)  AND C/均价1>(1+0.02);
H3:=C1>REF(C1,1) AND V1<REF(V1,1)  AND C/均价1>(1+0.034);
L1:=C1<REF(C1,1) AND V1>REF(V1,1)  AND C/均价1<(1-0.001);
L2:=C1<REF(C1,1) AND V1>REF(V1,1)  AND C/均价1<(1-0.02);
L3:=C1<REF(C1,1) AND V1>REF(V1,1)  AND C/均价1>(1+0.034);
IF(FILTER(H,240),C,DRAWNULL),COLORLIRED,LINETHICK3;
IF(FILTER(L,240),C,DRAWNULL),COLORGREEN,LINETHICK3;
IF(FILTER(H1,240),C,DRAWNULL),COLORLIRED,LINETHICK3;
IF(FILTER(L1,240),C,DRAWNULL),COLORCYAN,LINETHICK3;
IF(TT2,C,DRAWNULL),COLORRED,LINETHICK3;
IF(TT3,C,DRAWNULL),COLORGREEN,LINETHICK3;
VV:=CROSS(SUM(C<=REF(C,1),BARSLAST(H1))=1,0.5);
VVB:=CROSS(SUM(C>=REF(C,1),BARSLAST(L1))=1,0.5);
VV1:=CROSS(SUM(C<=REF(C,1),BARSLAST(H2))=1,0.5);
VVB1:=CROSS(SUM(C>=REF(C,1),BARSLAST(L2))=1,0.5);
VV23:=CROSS(SUM(C<=REF(C,1),BARSLAST(H3))=1,0.5);
VVB23:=CROSS(SUM(C>=REF(C,1),BARSLAST(L3))=1,0.5);
VVB2:=CROSS(SUM(VVB,0.5),0.5) ;
VV2:=CROSS(SUM(VV,0.5),0.5) ;
VAR2:CONST(SUM(IF(VVB2,REF(C,1),DRAWNULL),0)),COLORLIRED,LINETHICK1;
VAS2:CONST(SUM(IF(VV2,REF(C,1),DRAWNULL),0)),COLORCYAN,LINETHICK1;
VVB21:=CROSS(SUM(VVB1,0.5),0.5) ;
VV21:=CROSS(SUM(VV1,0.5),0.5) ;
VAR21:CONST(SUM(IF(VVB21,REF(C,1),DRAWNULL),0)),COLORLIRED,LINETHICK1;
VAS21:CONST(SUM(IF(VV21,REF(C,1),DRAWNULL),0)),COLORCYAN,LINETHICK1;
VVB22:=CROSS(SUM(VVB23,0.5),0.5) ;
VV22:=CROSS(SUM(VV23,0.5),0.5) ;
VAR22:CONST(SUM(IF(VVB22,REF(C,1),DRAWNULL),0)),COLORLIRED,LINETHICK1;
VAS22:CONST(SUM(IF(VV22,REF(C,1),DRAWNULL),0)),COLORCYAN,LINETHICK1;
VVB3:=IF(CROSS(SUM(CROSS(VVB AND C/VAR2<0.95,0.5),0),0.5) AND SUM(VVB,0)>1,1,0);
VV3:=IF(CROSS(SUM(CROSS(VV AND C/VAS2>1.05,0.5),0),0.5) AND SUM(VV,0)>1,1,0);
VAR3:CONST(SUM(IF(VVB3,REF(C,1),DRAWNULL),0)),COLORLIRED;
VAS3:CONST(SUM(IF(VV3,REF(C,1),DRAWNULL),0)),COLORCYAN;
VVB31:=IF(CROSS(SUM(CROSS(VVB1 AND C/VAR21<0.95,0.5),0),0.5) AND SUM(VVB1,0)>1,1,0);
VV31:=IF(CROSS(SUM(CROSS(VV1 AND C/VAS21>1.05,0.5),0),0.5) AND SUM(VV1,0)>1,1,0);
VAR31:CONST(SUM(IF(VVB31,REF(C,1),DRAWNULL),0)),COLORLIRED;
VAS31:CONST(SUM(IF(VV31,REF(C,1),DRAWNULL),0)),COLORCYAN;
VVB32:=IF(CROSS(SUM(CROSS(VVB2 AND C/VAR22<0.95,0.5),0),0.5) AND SUM(VVB23,0)>1,1,0);
VV32:=IF(CROSS(SUM(CROSS(VV2 AND C/VAS22>1.05,0.5),0),0.5) AND SUM(VV23,0)>1,1,0);
VAR32:CONST(SUM(IF(VVB32,REF(C,1),DRAWNULL),0)),COLORLIRED;
VAS32:CONST(SUM(IF(VV32,REF(C,1),DRAWNULL),0)),COLORCYAN;
DRAWTEXT(VVB31 AND REF(COUNT(V=HHV(V,6),5)>=1,1),REF(C,1)*0.999,'B'),COLORLIRED;
DRAWTEXT(VVB3 AND REF(COUNT(V=HHV(V,6),5)>=1,1),REF(C,1)*0.999,'B'),COLORLIRED;
DRAWTEXT(VVB21 AND REF(COUNT(V=HHV(V,6),5)>=1,1),REF(C,1)*0.999,'B'),COLORLIRED;

DRAWTEXT(VV31  ,REF(C,1)*1.003,'S'),COLORCYAN;
DRAWTEXT(VV3  ,REF(C,1)*1.003,'S'),COLORCYAN;
DRAWTEXT(VV21  ,REF(C,1)*1.003,'S'),COLORCYAN;
DRAWTEXT(VV22  ,REF(C,1)*1.003,'S'),COLORCYAN;


H11:=MAX(DYNAINFO(3),DYNAINFO(5));
L1K:=MIN(DYNAINFO(3),DYNAINFO(6));
P1K:=H11-L1;
阻力:L1K+P1K*7.7/8,NODRAW;
支撑:L1K+P1K*0.3/8,NODRAW;
STICKLINE(CROSS(支撑,现价),支撑,阻力,1,0),NODRAW;
个股基数:=自适应参数.GGS1#DAY;
个股基数2:=自适应参数.GGB1#DAY;
RSV:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
K:=SMA(RSV,14,1);
D:=SMA(K,5,1);
J:=3*K-2*D;
K1:=EMA(RSV,14);
D1:=EMA(D,5);
J1:=3*K1-2*D1;
JJX:=SUM(AMOUNT,0)/SUM(VOL,0)/100;
HH11:=C>REF(C,1) AND C/JJX>1.06;
LL11:=C<REF(C,1) AND C/JJX<0.94;
DRAWICON(CROSS(个股基数2,K1) AND EVERY(K1<D1,5) AND D1<REF(D1,1) OR FILTER(LL11,400) {OR (REF(D1,1)=0 AND REF(K1,1)=0 AND REF(J1,1)=0 AND J1>K1)},C*0.995,1);
DRAWICON(CROSS(K1,个股基数) AND EVERY(K1>D1,5) AND D1>REF(D1,1)  OR FILTER(HH11,400),C*1.005,2);

HHHH:="MKJS.HHHH#DAY";
LLLL:="MKJS.LLLL#DAY";
CCCC:="MKJS.CCCC#DAY";
OOOO:="MKJS.OOOO#DAY";
HHH1:=HHHH,COLORRED,LINETHICK1;
LLL1:=LLLL,COLORLIGREEN;
CCC1:=MAX(CCCC,OOOO),COLORRED,DOTLINE;
CCC2:=MIN(CCCC,OOOO),DOTLINE,COLORCYAN,LINETHICK1;
ZZZT:=CCCC*1.1;
GGG1:=(ZZZT-HHHH)*0.382+HHHH,COLORYELLOW,DOTLINE;
DDDT:=CCCC*0.9;
DDDD:=(LLLL-DDDT)*0.680+DDDT,COLORWHITE,DOTLINE;
分时均价:=SUM(V*C,0)/SUM(V,0),COLORYELLOW,DOTLINE;
AAA1:=C>=HHH1;
AAA2:=C<HHH1 AND C>=CCC1;
AAAA3:=C<CCC1 AND C>=CCC2;
AAA4:=C<CCC2 AND C>=LLLL;
AAA5:=C<LLLL;
BBB1:=REF(C,1)<HHH1 AND C>=HHH1 AND VOL>=REF(VOL,1);
BBB2:=REF(C,1)<HHH1 AND C>=HHH1 AND VOL<REF(VOL,1);
BBB3:=REF(C,1)>HHH1 AND C<=HHH1 AND VOL>=REF(VOL,1);
BBB4:=REF(C,1)>HHH1 AND C<=HHH1 AND VOL<REF(VOL,1);
DDD1:=REF(C,1)<CCC1 AND C>=CCC1 AND VOL>=REF(VOL,1);
DDD2:=REF(C,1)<CCC1 AND C>=CCC1 AND VOL<REF(VOL,1);
DDD3:=REF(C,1)>CCC1 AND C<=CCC1 AND VOL>=REF(VOL,1);
DDD4:=REF(C,1)>CCC1 AND C<=CCC1 AND VOL<REF(VOL,1);
EEE1:=REF(C,1)<CCC2 AND C>=CCC2 AND VOL>=REF(VOL,1);
EEE2:=REF(C,1)<CCC2 AND C>=CCC2 AND VOL<REF(VOL,1);
EEE3:=REF(C,1)>CCC2 AND C<=CCC2 AND VOL>=REF(VOL,1);
EEE4:=REF(C,1)>CCC2 AND C<=CCC2 AND VOL<REF(VOL,1);
FFF1:=REF(C,1)<LLLL AND C>=LLLL AND VOL>=REF(VOL,1);
FFF2:=REF(C,1)<LLLL AND C>=LLLL AND VOL<REF(VOL,1);
FFF3:=REF(C,1)>LLLL AND C<=LLLL AND VOL>=REF(VOL,1);
FFF4:=REF(C,1)>LLLL AND C<=LLLL AND VOL<REF(VOL,1);
DRAWTEXT_FIX(AAA1 AND ISLASTBAR,0.050,0.005,0,'【强势】'),COLORRED;
DRAWTEXT_FIX(AAA2 AND ISLASTBAR,0.050,0.005,0,'【强】'),COLORMAGENTA;
DRAWTEXT_FIX(AAAA3 AND ISLASTBAR,0.050,0.005,0,'【一般】'),COLORYELLOW;
DRAWTEXT_FIX(AAA4 AND ISLASTBAR,0.050,0.005,0,'【弱】'),COLORCYAN;
DRAWTEXT_FIX(AAA5 AND ISLASTBAR,0.050,0.005,0,'【弱势】'),COLORGREEN;
DRAWTEXT_FIX((BBB1 OR DDD1 OR EEE1 OR FFF1)AND ISLASTBAR,0.5,0.75,0,'【放量突破】'),COLORRED;
DRAWTEXT_FIX((BBB2 OR DDD2 OR EEE2 OR FFF2)AND ISLASTBAR,0.5,0.75,0,'【缩量突破】'),COLORYELLOW;
DRAWTEXT_FIX((BBB3 OR DDD3 OR EEE3 OR FFF3)AND ISLASTBAR,0.5,0.75,0,'【放量跌破】'),COLORGREEN;
DRAWTEXT_FIX((BBB4 OR DDD4 OR EEE4 OR FFF4)AND ISLASTBAR,0.5,0.75,0,'【缩量跌破】'),COLORCYAN;
TTT:=VARCAT(VARCAT('昨高:',VAR2STR(HHHH,2)),'元');
TTT1:=VARCAT(VARCAT('昨低:',VAR2STR(LLLL,2)),'元');
TTT2:=VARCAT(VARCAT('昨开:',VAR2STR(CCCC,2)),'元');
TTT3:=VARCAT(VARCAT('昨收:',VAR2STR(OOOO,2)),'元');
TTT4:=VARCAT(VARCAT('压力位:',VAR2STR(GGG1,2)),'元');
TTT5:=VARCAT(VARCAT('止损价:',VAR2STR(DDDD,2)),'元');
DRAWTEXT_FIX(ISLASTBAR,0.5,0.95,0,TTT),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.6,0.95,0,TTT1),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR AND CCCC>=OOOO,0.7,0.95,0,TTT2),COLOR0033CC;
DRAWTEXT_FIX(ISLASTBAR AND CCCC<OOOO,0.7,0.95,0,TTT2),COLOR0033CC;
DRAWTEXT_FIX(ISLASTBAR AND CCCC>=OOOO,0.8,0.95,0,TTT3),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR AND CCCC<OOOO,0.8,0.95,0,TTT3),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.5,0.89,0,TTT4),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.6,0.89,0,TTT5),COLORWHITE;

VAR1:=EMA(EMA(C,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
JJ:=DYNAINFO(11);
P:=55;
S:=8;
M1:=3;
能量:=(EMA(C,S)-EMA(C,P))*10;
空头:=EMA(能量,M1);
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ3:=CROSS(能量,空头) AND 能量<-0.3;
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
有庄:=BTJ811;
DRAWTEXT(BTJ811,C*0.999,'●有庄'),COLORRED;

 股票专家荐股少而精.成功率达95%免费个股咨询点这里

 想了解手头持有个股接下来的走势个股论坛-股票吧点击这里

为什么我下载南川三代的指标编译不通过?..更多详情请加腾飞涨停微信:gupiao139

相关热词搜索:通达信 指标编写互助答疑区

上一篇:求助老师帮写个选股公式
下一篇:大神帮忙写一下上一分钟总的成交量大于近3000分钟内的任何一分钟的总成交量;

本栏点击总排行
分享到: 收藏
短信荐股回顾
邮件传真荐股回顾
整网点击月排行
整网点击排行