定量结构公式···修改为预警条件公式(已解答:齐备)
2016-12-07 23:27:00   来源:股票壹网   评论:0 点击:

定量结构公式···修改为预警条件公式(已解答:齐备) {红钝化预警} DIF:=EMA(CLOSE,12)-EMA(CLOSE,26); DEA:=EMA(DIF,9); MACD:=(DIF-DEA)*2; 死叉:=CROSS(DEA,DIF); N1:=BARSLAST(死叉);{最近一次死叉的位置
  定量结构公式···修改为预警条件公式(已解答:齐备)
{红钝化预警}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉);{最近一次死叉的位置}
CL1:=LLV(C,N1+1);{最近一次死叉后,最低收盘价}
DIFL1:=LLV(DIF,N1+1);
CL2:=REF(CL1,N1+1);{倒数第二次死叉与倒数第一次死叉之间的最低收盘价}
DIFL2:=REF(DIFL1,N1+1);
CL3:=REF(CL2,N1+1);{倒数第三次死叉与倒数第二次死叉之间的最低收盘价}
DIFL3:=REF(DIFL2,N1+1);
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背离:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背离:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
B:=直接底背离 OR 隔峰底背离;
BG:=((MDIFB2>REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背离,1));
底背离消失:=(REF(直接底背离,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背离,1) AND DIFL1<=DIFL3);
XG:TFILTER(B,MACD>0,1);--{底部结构}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉);{最近一次死叉的位置}
CL1:=LLV(C,N1+1);{最近一次死叉后,最低收盘价}
DIFL1:=LLV(DIF,N1+1);
CL2:=REF(CL1,N1+1);{倒数第二次死叉与倒数第一次死叉之间的最低收盘价}
DIFL2:=REF(DIFL1,N1+1);
CL3:=REF(CL2,N1+1);{倒数第三次死叉与倒数第二次死叉之间的最低收盘价}
DIFL3:=REF(DIFL2,N1+1);
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背离:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背离:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
B:=直接底背离 OR 隔峰底背离;
BG:=((MDIFB2>REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背离,1));
底背离消失:=(REF(直接底背离,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背离,1) AND DIFL1<=DIFL3);
{红钝化:TFILTER(B,MACD>0,1);}
结构形成:TFILTER(BG,MACD>0,1);--谢谢分享--谢谢分享!!!!!!--说真的,你这指标不错了,就是分散。--谢谢   好东西一个--希望有用,谢谢分享。--谢谢分享。--谢谢分享!!--谢谢楼主分享!!!--@齐备 谢谢老师--@齐备

N:=(20);P:=(12);
阻挡线:=SMA(HIGH,21,2)*1.035,POINTDOT,COLORFFFFFF;
下档线:=SMA(LOW,21,2)*0.96,POINTDOT;
上:=EMA(MA(HIGH,3)*1.05,30); {原句 上:=FFT(MA(HIGH,3)*1.05,30);分析家无FFT,故改}
趋势:=EMA(MA(LOW,3)*0.96,30); {原句 趋势:=FFT(MA(LOW,3)*0.96,30);分析家无FFT,故改}
短期支撑:=LLV(CLOSE,N),COLOR6803C7;
中:=EMA(MA(OPEN,3)*0.99,30); {原句 中:=FFT(MA(OPEN,3)*0.99,30);分析家无FFT,故改}
趋势线:=SMA(LOW,8,1);
VAR1:=(OPEN+LOW+HIGH+CLOSE)/4;
VAR2:=((CLOSE-REF(CLOSE,1))/REF(CLOSE,1))*100;
VAR3:=((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18)))*100;
VAR4:=SMA(VAR3,9,1);
VAR5:=SMA(VAR4,3,1);
J:=3*VAR4-2*VAR5;
A2:=EMA(VAR4,3);
A3:=EMA(A2,3);
A4:=EMA(A3,3);
A5:=EMA(A4,3);
AA:=EMA(A5,6);
中期大底:=LLV(LOW,30),COLORCDFFBB;
VAR9:=HHVBARS(HIGH,50);
VAR11:=((CLOSE-REF(OPEN,VAR9))/REF(OPEN,VAR9))*100;


CG:=MA(CLOSE,19);
CD:=MA(CLOSE,2);
MA20:=MA(CLOSE,20);
MA120:=MA(CLOSE,120);
支撑:=EMA(VAR1,5);
压力一:=HHV(LOW,20),,COLOR00FFFF;
压力:=HHV(支撑,60);
短期底部:=LLV(HIGH,30),COLOR00FF00;
DRAWTEXT(FILTER(((((((CLOSE>CG) AND (HIGH<上)) AND (CLOSE <上)) AND ((趋势线-REF(趋势线,3))>0)) AND ((趋势-REF(趋势,1))>=0)) AND CROSS(CD,CG)),5),(LOW-0.02),'★大底成'),COLOR4D84FF;
DRAWTEXT(FILTER(((CROSS(趋势,中期大底) AND (LOW<=中)) AND ((趋势-REF(趋势,1))>0)),3),(中期大底-0.08),'←分时拉升'),COLORFF00FF;
DRAWTEXT(FILTER((CROSS(中,短期底部) AND ((趋势-REF(趋势,1))>0)),4),(中期大底-0.16),'←分时狂牛'),COLOR430CC0;

上一:=(SMA(HIGH,21,2)*1.05);
DRAWTEXT((((((CLOSE<REF(CLOSE,1)) AND ((上-REF(上,1))<0)) AND (CLOSE<REF(CLOSE,1))) AND (HIGH>上一)) AND (CLOSE<上一)),(HIGH+0.13),'←分时短线'),COLORFFFFFF;

VARQ:=MA(CLOSE,152);         
VARW:=MA(CLOSE,194.16);
VARE:=(VARW+(2*STD(CLOSE,170)));
VARR:=(VARQ+(2*STD(CLOSE,170)));
VART:=IF((DATE>1880822),1,1);
VAR61:=EMA(HHV(HIGH,500),21);
VAR71:=EMA(HHV(HIGH,250),21);
VAR81:=EMA(HHV(HIGH,90),21);
VAR91:=EMA(LLV(LOW,500),21);
VARA1:=EMA(LLV(LOW,250),21);
VARB1:=EMA(LLV(LOW,90),21);
VARC1:=EMA(((VAR91*0.96+VARA1*0.96+VARB1*0.96+VAR61*0.558+VAR71*0.558+VAR81*0.558)/6),21);
VARD1:=EMA(((VAR91*1.25+VARA1*1.23+VARB1*1.20+VAR61*0.550+VAR71*0.550+VAR81*0.650)/6),21);
VARE1:=EMA(((VAR91*1.30+VARA1*1.30+VARB1*1.30+VAR61*0.680+VAR71*0.680+VAR81*0.680)/6),21);
VARF1:=EMA((((VARC1*3+VARD1*2+VARE1)/6)* 1.738),21);

VAR101:=REF(LOW,1);
VAR111:=((SMA(ABS((LOW-VAR101)),3,1)/SMA(MAX((LOW-VAR101),0),3,1))*100);
VAR121:=EMA(IF(((CLOSE*1.35)<=VARF1),(VAR111*10),(VAR111/10)),3);
VAR131:=LLV(LOW,30);
VAR141:=HHV(VAR121,30);
VAR151:=IF(MA(CLOSE,58),1,0);
VAR161:=(EMA(IF((LOW<=VAR131),((VAR121+(VAR141*2))/2),0),3)/618)*VAR151;
VAR171:=((IF((VAR161>50),50,VAR161)/20)*15)*VART;
主力吸筹:=VAR171>中期大底,COLORFF00FF,LINETHICK0;

DRAWTEXT(FILTER((((((LOW<=趋势) AND (CLOSE>趋势)) AND (VAR171>0)) AND ((趋势-REF(趋势,1))>0)) AND (CLOSE>OPEN)),5),(LOW-0.04),'←分时黑马'),COLOR8CF800;

B1:=(HIGH+LOW+CLOSE)/3;
B6:=HHV(B1,4*15);
B7:=LLV(B1,4*15);
B8:=B6-B7;
飞龙顶底线:=MA(((B1-B7)/B8),2)*80;

X7:=EMA(EMA(EMA(HIGH,9),9),9);
海底:=X7*0.92;
海底二:=X7*0.933;
海底三:=X7*0.897;
天际:=X7*1.05;
中线:=SMA(LOW,5,1);
中轨道:=MA(CLOSE,2);
DRAWTEXT(FILTER(((((HIGH>压力) AND (CLOSE<压力)) AND ((趋势-REF(趋势,1))<0)) AND (CLOSE<OPEN)),5),(HIGH+0.12),'●逃'),COLORFFFF00;
MA12:=MA(CLOSE,P);
MA42:=MA(CLOSE,42);
{DRAWTEXT((((CROSS(中轨道,均五) AND (LOW<=海底)) AND ((均五-REF(均五,1))>0)) AND (CLOSE>=海底二)),LOW,'     底部'),COLOR00FFFF;
DRAWTEXT(((((CROSS(中轨道,海底) AND VAR171) AND (LOW<=海底)) AND ((MA20-REF(MA20,1))>0)) AND (CLOSE>海底)),(LOW-0.06),'小底不急');
DRAWTEXT(((((CROSS(中轨道,海底三) AND (CLOSE>OPEN)) AND ((CLOSE-REF(CLOSE,4))>0)) AND (LOW<=海底三)) AND (CLOSE>海底三)),LOW,'底二');}
MA30:=MA(CLOSE,30);

V1:=HHVBARS(HIGH,100);
V2:=CROSS(MA(CLOSE,10),MA(CLOSE,30));
V3:=(V1>60 AND V2)*100;
DRAWTEXT((((((V3 AND (HIGH<上)) AND (CLOSE<压力)) AND (CLOSE>OPEN)) AND ((上-REF(上,1))>0)) AND ((趋势-REF(趋势,1))>0)),(LOW-0.04),'←量价齐升'),COLOR8B0CFF;
DRAWTEXT(((((V3 AND (HIGH<趋势)) AND (HIGH<天际)) AND ((支撑-REF(支撑,1))>0)) AND ((MA20-REF(MA20,1))>0)),(LOW-0.03),'分时波段介入'),COLOR5BA8FF;
DRAWTEXT(((CROSS(趋势,MA12) AND (CLOSE>OPEN)) AND ((趋势-REF(趋势,1))>0)),LOW,'★分时果断');
DRAWTEXT(FILTER(((((((((CROSS(支撑,MA12) AND ((MA12-REF(MA12,1))>0)) AND (HIGH<上)) AND (OPEN<压力一)) AND ((CLOSE-REF(CLOSE,1))>0)) AND ((MA42-REF(MA42,1))>0)) AND (支撑<压力)) AND (支撑>MA12)) AND ((趋势-REF(趋势,1))>0)),6),(LOW-0.02),'←分时回抽'),COLOR4DFFFF;
DRAWTEXT((((LOW<=趋势) AND (CLOSE>=支撑)) AND ((MA120-REF(MA120,1))>0)),(LOW-0.35),'抄底'),COLORFF0000;
DRAWTEXT(FILTER(((((((LOW<=短期底部) AND ((上-REF(上,1))>0)) AND ((上-REF(上,1))>0)) AND (CLOSE>OPEN)) AND (趋势线<=短期底部)) AND (CLOSE>=短期底部)),5),(LOW-0.03),'←分时望月');
VAR22:=(CLOSE+HIGH+LOW)/3;
VAR33:=EMA(VAR22,10);
VAR44:=REF(VAR33,1);
DRAWTEXT(FILTER((((LOW<=中期大底) AND ((趋势-REF(趋势,1))>0)) AND VAR171),5),(LOW-0.03),'←●买点出现');
DRAWTEXT(((((LOW<=下档线) AND (LOW<=短期支撑)) AND (短期支撑<=下档线)) AND ((MA20-REF(MA20,1))> 0)),LOW,'←绝佳买点'),COLORFF0000;
DRAWTEXT(((((CROSS(VAR33,MA20) AND (LOW<=VAR33)) AND (CLOSE>= VAR33)) AND ((趋势-REF(趋势,2))>0)) AND ((VAR33-REF(VAR33,1))>0)),LOW,'←回头望月'),COLORFFFFFF;
DRAWTEXT(FILTER((((HIGH>压力) AND (CLOSE<压力)) AND (HIGH>阻挡线)),8),HIGH,'←减仓'),COLORB0FA00;
麻烦能做个分时望月的选股公式吗?谢谢!!!!--@偷闲888 {分时望月选股}
上:=EMA(MA(HIGH,3)*1.05,30); {原句 上:=FFT(MA(HIGH,3)*1.05,30);分析家无FFT,故改}
趋势线:=SMA(LOW,8,1);
短期底部:=LLV(HIGH,30),COLOR00FF00;
分时望月选股:FILTER(((((((LOW<=短期底部) AND ((上-REF(上,1))>0)) AND ((上-REF(上,1))>0)) AND (CLOSE>OPEN)) AND (趋势线<=短期底部)) AND
(CLOSE>=短期底部)),5);--
引用:
原帖由 @齐备 于 2016-12-15 00:01 发表
偷闲888 {分时望月选股}
上:=EMA(MA(HIGH,3)*1.05,30); {原句 上:=FFT(MA(HIGH,3)*1.05,30);分析家无FFT,故改}
趋势线:=SMA(LOW,8,1);
短期底部:=LLV(HIGH,30),COLOR00FF00;
分时望月选股:FILTER(((((((LOW0))  ...    
@谢谢齐备!!! 祝您年年如意财貌多多!!!--
引用:
原帖由 @齐备 于 2016-12-15 00:01 发表
偷闲888 {分时望月选股}
上:=EMA(MA(HIGH,3)*1.05,30); {原句 上:=FFT(MA(HIGH,3)*1.05,30);分析家无FFT,故改}
趋势线:=SMA(LOW,8,1);
短期底部:=LLV(HIGH,30),COLOR00FF00;
分时望月选股:FILTER(((((((LOW0))  ...    
N:=(20);P:=(12);
阻挡线:=SMA(HIGH,21,2)*1.035,POINTDOT,COLORFFFFFF;
下档线:=SMA(LOW,21,2)*0.96,POINTDOT;
上:=EMA(MA(HIGH,3)*1.05,30); {原句 上:=FFT(MA(HIGH,3)*1.05,30);分析家无FFT,故改}
趋势:=EMA(MA(LOW,3)*0.96,30); {原句 趋势:=FFT(MA(LOW,3)*0.96,30);分析家无FFT,故改}
短期支撑:=LLV(CLOSE,N),COLOR6803C7;
中:=EMA(MA(OPEN,3)*0.99,30); {原句 中:=FFT(MA(OPEN,3)*0.99,30);分析家无FFT,故改}
趋势线:=SMA(LOW,8,1);
VAR1:=(OPEN+LOW+HIGH+CLOSE)/4;
VAR2:=((CLOSE-REF(CLOSE,1))/REF(CLOSE,1))*100;
VAR3:=((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18)))*100;
VAR4:=SMA(VAR3,9,1);
VAR5:=SMA(VAR4,3,1);
J:=3*VAR4-2*VAR5;
A2:=EMA(VAR4,3);
A3:=EMA(A2,3);
A4:=EMA(A3,3);
A5:=EMA(A4,3);
AA:=EMA(A5,6);
中期大底:=LLV(LOW,30),COLORCDFFBB;
VAR9:=HHVBARS(HIGH,50);
VAR11:=((CLOSE-REF(OPEN,VAR9))/REF(OPEN,VAR9))*100;


CG:=MA(CLOSE,19);
CD:=MA(CLOSE,2);
MA20:=MA(CLOSE,20);
MA120:=MA(CLOSE,120);
支撑:=EMA(VAR1,5);
压力一:=HHV(LOW,20),,COLOR00FFFF;
压力:=HHV(支撑,60);
短期底部:=LLV(HIGH,30),COLOR00FF00;
DRAWTEXT(FILTER(((((((CLOSE>CG) AND (HIGH<上)) AND (CLOSE <上)) AND ((趋势线-REF(趋势线,3))>0)) AND ((趋势-REF(趋势,1))>=0)) AND CROSS(CD,CG)),5),(LOW-0.02),"★大底成'),COLOR4D84FF;
DRAWTEXT(FILTER(((CROSS(趋势,中期大底) AND (LOW<=中)) AND ((趋势-REF(趋势,1))>0)),3),(中期大底-0.08),'←分时拉升'),COLORFF00FF;
DRAWTEXT(FILTER((CROSS(中,短期底部) AND ((趋势-REF(趋势,1))>0)),4),(中期大底-0.16),'←分时狂牛'),COLOR430CC0;

上一:=(SMA(HIGH,21,2)*1.05);
DRAWTEXT((((((CLOSE<REF(CLOSE,1)) AND ((上-REF(上,1))<0)) AND (CLOSE<REF(CLOSE,1))) AND (HIGH>上一)) AND (CLOSE<上一)),(HIGH+0.13),'←分时短线'),COLORFFFFFF;

VARQ:=MA(CLOSE,152);         
VARW:=MA(CLOSE,194.16);
VARE:=(VARW+(2*STD(CLOSE,170)));
VARR:=(VARQ+(2*STD(CLOSE,170)));
VART:=IF((DATE>1880822),1,1);
VAR61:=EMA(HHV(HIGH,500),21);
VAR71:=EMA(HHV(HIGH,250),21);
VAR81:=EMA(HHV(HIGH,90),21);
VAR91:=EMA(LLV(LOW,500),21);
VARA1:=EMA(LLV(LOW,250),21);
VARB1:=EMA(LLV(LOW,90),21);
VARC1:=EMA(((VAR91*0.96+VARA1*0.96+VARB1*0.96+VAR61*0.558+VAR71*0.558+VAR81*0.558)/6),21);
VARD1:=EMA(((VAR91*1.25+VARA1*1.23+VARB1*1.20+VAR61*0.550+VAR71*0.550+VAR81*0.650)/6),21);
VARE1:=EMA(((VAR91*1.30+VARA1*1.30+VARB1*1.30+VAR61*0.680+VAR71*0.680+VAR81*0.680)/6),21);
VARF1:=EMA((((VARC1*3+VARD1*2+VARE1)/6)* 1.738),21);

VAR101:=REF(LOW,1);
VAR111:=((SMA(ABS((LOW-VAR101)),3,1)/SMA(MAX((LOW-VAR101),0),3,1))*100);
VAR121:=EMA(IF(((CLOSE*1.35)<=VARF1),(VAR111*10),(VAR111/10)),3);
VAR131:=LLV(LOW,30);
VAR141:=HHV(VAR121,30);
VAR151:=IF(MA(CLOSE,58),1,0);
VAR161:=(EMA(IF((LOW<=VAR131),((VAR121+(VAR141*2))/2),0),3)/618)*VAR151;
VAR171:=((IF((VAR161>50),50,VAR161)/20)*15)*VART;
主力吸筹:=VAR171>中期大底,COLORFF00FF,LINETHICK0;

DRAWTEXT(FILTER((((((LOW<=趋势) AND (CLOSE>趋势)) AND (VAR171>0)) AND ((趋势-REF(趋势,1))>0)) AND (CLOSE>OPEN)),5),(LOW-0.04),'←分时黑马'),COLOR8CF800;

B1:=(HIGH+LOW+CLOSE)/3;
B6:=HHV(B1,4*15);
B7:=LLV(B1,4*15);
B8:=B6-B7;
飞龙顶底线:=MA(((B1-B7)/B8),2)*80;

X7:=EMA(EMA(EMA(HIGH,9),9),9);
海底:=X7*0.92;
海底二:=X7*0.933;
海底三:=X7*0.897;
天际:=X7*1.05;
中线:=SMA(LOW,5,1);
中轨道:=MA(CLOSE,2);
DRAWTEXT(FILTER(((((HIGH>压力) AND (CLOSE<压力)) AND ((趋势-REF(趋势,1))<0)) AND (CLOSE<OPEN)),5),(HIGH+0.12),'●逃'),COLORFFFF00;
MA12:=MA(CLOSE,P);
MA42:=MA(CLOSE,42);
{DRAWTEXT((((CROSS(中轨道,均五) AND (LOW<=海底)) AND ((均五-REF(均五,1))>0)) AND (CLOSE>=海底二)),LOW,'     底部'),COLOR00FFFF;
DRAWTEXT(((((CROSS(中轨道,海底) AND VAR171) AND (LOW<=海底)) AND ((MA20-REF(MA20,1))>0)) AND (CLOSE>海底)),(LOW-0.06),'小底不急');
DRAWTEXT(((((CROSS(中轨道,海底三) AND (CLOSE>OPEN)) AND ((CLOSE-REF(CLOSE,4))>0)) AND (LOW<=海底三)) AND (CLOSE>海底三)),LOW,'底二');}
MA30:=MA(CLOSE,30);

V1:=HHVBARS(HIGH,100);
V2:=CROSS(MA(CLOSE,10),MA(CLOSE,30));
V3:=(V1>60 AND V2)*100;
DRAWTEXT((((((V3 AND (HIGH<上)) AND (CLOSE<压力)) AND (CLOSE>OPEN)) AND ((上-REF(上,1))>0)) AND ((趋势-REF(趋势,1))>0)),(LOW-0.04),'←量价齐升'),COLOR8B0CFF;
DRAWTEXT(((((V3 AND (HIGH<趋势)) AND (HIGH<天际)) AND ((支撑-REF(支撑,1))>0)) AND ((MA20-REF(MA20,1))>0)),(LOW-0.03),'分时波段介入'),COLOR5BA8FF;
DRAWTEXT(((CROSS(趋势,MA12) AND (CLOSE>OPEN)) AND ((趋势-REF(趋势,1))>0)),LOW,'★分时果断');
DRAWTEXT(FILTER(((((((((CROSS(支撑,MA12) AND ((MA12-REF(MA12,1))>0)) AND (HIGH<上)) AND (OPEN<压力一)) AND ((CLOSE-REF(CLOSE,1))>0)) AND ((MA42-REF(MA42,1))>0)) AND (支撑<压力)) AND (支撑>MA12)) AND ((趋势-REF(趋势,1))>0)),6),(LOW-0.02),'←分时回抽'),COLOR4DFFFF;
DRAWTEXT((((LOW<=趋势) AND (CLOSE>=支撑)) AND ((MA120-REF(MA120,1))>0)),(LOW-0.35),'抄底'),COLORFF0000;
DRAWTEXT(FILTER(((((((LOW<=短期底部) AND ((上-REF(上,1))>0)) AND ((上-REF(上,1))>0)) AND (CLOSE>OPEN)) AND (趋势线<=短期底部)) AND (CLOSE>=短期底部)),5),(LOW-0.03),'←分时望月');
VAR22:=(CLOSE+HIGH+LOW)/3;
VAR33:=EMA(VAR22,10);
VAR44:=REF(VAR33,1);
DRAWTEXT(FILTER((((LOW<=中期大底) AND ((趋势-REF(趋势,1))>0)) AND VAR171),5),(LOW-0.03),'←●买点出现');
DRAWTEXT(((((LOW<=下档线) AND (LOW<=短期支撑)) AND (短期支撑<=下档线)) AND ((MA20-REF(MA20,1))> 0)),LOW,'←绝佳买点'),COLORFF0000;
DRAWTEXT(((((CROSS(VAR33,MA20) AND (LOW<=VAR33)) AND (CLOSE>= VAR33)) AND ((趋势-REF(趋势,2))>0)) AND ((VAR33-REF(VAR33,1))>0)),LOW,'←回头望月'),COLORFFFFFF;
DRAWTEXT(FILTER((((HIGH>压力) AND (CLOSE<压力)) AND (HIGH>阻挡线)),8),HIGH,'←减仓'),COLORB0FA00;
@齐备麻烦能再做个分时短线的选股公式吗?谢谢!!!!

--@偷闲888 {分时短线选股}
上:=EMA(MA(HIGH,3)*1.05,30);
上一:=(SMA(HIGH,21,2)*1.05);
分时短线选股:(((((CLOSE<REF(CLOSE,1)) AND ((上-REF(上,1))<0)) AND (CLOSE<REF(CLOSE,1))) AND (HIGH>上一)) AND (CLOSE<上一));--
引用:
原帖由 @齐备 于 2016-12-16 00:01 发表
偷闲888 {分时短线选股}
上:=EMA(MA(HIGH,3)*1.05,30);
上一:=(SMA(HIGH,21,2)*1.05);
分时短线选股:(((((CLOSE    
@齐备谢谢!!! 祝您年年如意财貌多多!!!好人好运!!!! --定量结构及预警公式,能否改成大智慧的啊,请各位老师帮忙!--谢谢分享,收藏了学习
 权仔王子:   2016-12-7 23:27
   请老师帮忙把这个交易师的定量结构公式改成预警条件公式,谢谢
改成结构形成的预警。


DIF:100*(EMA(CLOSE,SHORT)-EMA(CLOSE,LONG));
DEA:EMA(DIF,MID);
MACD:(DIF-DEA)*2,COLORSTICK;

{底部结构预警}
死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉),NODRAW;{最近一次死叉的位置}
N2:=REF(BARSLAST(死叉),N1+1),NODRAW;{倒数第二次死叉与倒数第一次死叉的区间}
N3:=REF(BARSLAST(死叉),N2+N1+2),NODRAW;{倒数第三次死叉与倒数第二次死叉的区间}
CL1:=LLV(C,N1+1),NODRAW;{最近一次死叉后,最低收盘价}
DIFL1:=LLV(DIF,N1+1),NODRAW;

CL2:=REF(CL1,N1+1),NODRAW;{倒数第二次死叉与倒数第一次死叉之间的最低收盘价}
DIFL2:=REF(DIFL1,N1+1),NODRAW;
CL3:=REF(CL2,N1+1),NODRAW;{倒数第三次死叉与倒数第二次死叉之间的最低收盘价}
DIFL3:=REF(DIFL2,N1+1),NODRAW;
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背离:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背离:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
B:直接底背离 OR 隔峰底背离,NODRAW;
BG:((MDIFB2>REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背离,1)),NODRAW;
底背离消失:=(REF(直接底背离,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背离,1) AND DIFL1<=DIFL3);
DRAWTEXT(TFILTER(B,MACD>0,1),(DIF+MACD),"钝化'),COLORRED;
STICKLINE(B OR BG,DIF,DEA,1,0),COLORRED;
DRAWTEXT(TFILTER(底背离消失,B,1),(DIF+MACD),'消失'),COLORYELLOW;
DRAWTEXT(TFILTER(BG,MACD>0,1),DIF*1.1,'结构形成'),COLORMAGENTA;

{顶部结构预警}

金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉),NODRAW;{最近一次金叉的位置}
M2:=REF(BARSLAST(金叉),M1+1),NODRAW;{倒数第二次金叉与倒数第一次金叉的区间}
M3:=REF(BARSLAST(金叉),M2+M1+2),NODRAW;{倒数第三次金叉与倒数第二次金叉的区间}
CH1:=HHV(C,M1+1),NODRAW;{最近一次金叉后,最高收盘价}
DIFH1:=HHV(DIF,M1+1),NODRAW;

CH2:=REF(CH1,M1+1),NODRAW;{倒数第二次金叉与倒数第一次金叉之间的最高收盘价}
DIFH2:=REF(DIFH1,M1+1),NODRAW;
CH3:=REF(CH2,M1+1),NODRAW;{倒数第三次金叉与倒数第二次金叉之间的最高收盘价}
DIFH3:=REF(DIFH2,M1+1),NODRAW;
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接顶背离:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰顶背离:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
T:直接顶背离 OR 隔峰顶背离,NODRAW;
TG:((MDIFT2<REF(MDIFT2,1))*REF(直接顶背离,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰顶背离,1)),NODRAW;
顶背离消失:=(REF(直接顶背离,1) AND DIFH1>=DIFH2 ) OR (REF(隔峰顶背离,1) AND DIFH1>=DIFH3);
DRAWTEXT(TFILTER(T,MACD<0,1),(DIF+MACD),'钝化'),COLORGREEN;
DRAWTEXT(TFILTER(顶背离消失,T,1),(DIF+MACD),'消失'),COLORYELLOW;
STICKLINE(T OR TG,DIF,DEA,1,0),COLORGREEN;
DRAWTEXT(TFILTER(TG,MACD<0,1),DIF*1.02,'结构形成'),COLORMAGENTA;

[ 本帖最后由 任刚 于 2016-12-9 08:04 编辑 ]

 股票专家荐股少而精.成功率达95%免费个股咨询点这里

 想了解手头持有个股接下来的走势个股论坛-股票吧点击这里

定量结构公式···修改为预警条件公式(已解答:齐备)..更多详情请加腾飞涨停微信:gupiao139

相关热词搜索:通达信 MDI

上一篇:请老师把以下“慢建仓”指标公式按要求修改为条件选股公式(已解答:天河饮马)
下一篇:请老师编一个《低开高走》选股指标(已解答:股述)

本栏点击总排行
分享到: 收藏
短信荐股回顾
邮件传真荐股回顾
整网点击月排行
整网点击排行