烦请老师将这个“仙人指路[副图]”改为通达信版的选股公式(已解答:葫芦岛15)
2016-10-02 11:09:00   来源:股票壹网   评论:0 点击:

烦请老师将这个“仙人指路[副图]”改为通达信版的选股公式(已解答:葫芦岛15) @莫易坚 多:=EMA(C,3); 空:=EMA(C,5); 均衡:=EMA(空,5); VARF1:=COUNT(CROSS(多,均衡),2)=1; VARF2:=COUNT(CROSS(空,均衡),2)=1
  烦请老师将这个“仙人指路[副图]”改为通达信版的选股公式(已解答:葫芦岛15)
@莫易坚
多:=EMA(C,3);
空:=EMA(C,5);
均衡:=EMA(空,5);
VARF1:=COUNT(CROSS(多,均衡),2)=1;
VARF2:=COUNT(CROSS(空,均衡),2)=1;
ZAI:FILTER(VARF1 AND VARF2,2);--@莫易坚

买线:=EMA(C,3),COLORWHITE;
卖线:=EMA(SLOPE(C,21)*20+C,55);
CROSS(买线,卖线);--@葫芦岛15
非常感谢葫芦岛15老师!--@愤怒的猪哥
同时,也要感谢愤怒的猪哥老师。--@愤怒的猪哥 老师 你好 麻烦你 今天的量只有昨天的一半甚至更低 这个选股公式应该怎么写 谢谢你了--@贵派
v<=ref(v,1)*0.5;--谢谢老师!!!!!!!!!!!!!!--@葫芦岛15 老师您好 麻烦你将这两个选股公式合并成一个选股公式 谢谢你了 源码如下  VAR2:=(2*CLOSE+HIGH+LOW)/4;
VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,4);
散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3;
CROSS(散户,庄家) AND 散户<50 AND 29<散户;


VAR1C:=(HIGH - MIN(OPEN,CLOSE));
VAR2C:=(CLOSE - OPEN);
VAR3C:=(MIN(OPEN,CLOSE) - LOW);
VAR4C:=(HIGH - LOW);
VAR5C:=((VOL * VAR1C) / VAR4C);
VAR6C:=((VOL * VAR2C) / VAR4C);
VAR7C:=((VOL * VAR3C) / VAR4C);
VAR8C:=((VAR5C - VAR6C) - VAR7C);
VAR4:=MA(CLOSE,5);
VAR5:=MA(CLOSE,10);
VAR6:=MA(CLOSE,30);
VAR7:=MA(CLOSE,60);
VAR8:=EMA(COST(85),7);
VAR9:=EMA(COST(15),7);
VARA:=(SUM(((CLOSE * VOL) * 100),4) / SUM((VOL * 100),4));
VARB:=(INTPART((VARA * 100)) / 100);
VARC:=(SUM(((CLOSE * VOL) * 100),7) / SUM((VOL * 100),7));
VARD:=(INTPART((VARC * 100)) / 100);
VARE:=(SUM(((CLOSE * VOL) * 100),28) / SUM((VOL * 100),28));
VARF:=(INTPART((VARE * 100)) / 100);
短线趋势:=(EMA(CLOSE,5) - EMA(CLOSE,10));
中线趋势:=EMA(短线趋势,9);
VAR10:=((0 - ((100 * (HHV(CLOSE,5) - CLOSE)) / (HHV(CLOSE,5) - LLV(LOW,5)))) + 100);
VAR11:=((0 - ((100 * (HHV(CLOSE,10) - CLOSE)) / (HHV(CLOSE,10) - LLV(LOW,10)))) + 100);
VAR12:=((0 - ((100 * (HHV(CLOSE,20) - CLOSE)) / (HHV(CLOSE,20) - LLV(LOW,20)))) + 100);
VAR13:=((0 - ((100 * (HHV(CLOSE,30) - CLOSE)) / (HHV(CLOSE,30) - LLV(LOW,30)))) + 100);
VAR14:=REF(中线趋势,1);
VAR15:=中线趋势;
VAR16:=(VAR15 - VAR14);
VAR17:=REF(短线趋势,1);
VAR18:=短线趋势;
VAR19:=(VAR18 - VAR17);
VAR1A:=OPEN;
VAR1B:=CLOSE;
(((((((VAR1A <= VAR4) AND (VAR1A <= VAR5)) AND (VAR1A <= VAR6)) AND (VAR1B >= VAR4)) AND (VAR1B >= VARF)) AND (VAR16 > 0)) AND (VAR19 > 0)) AND DYNAINFO(4)>0
AND REF(C,1)<REF(O,1) AND REF(C,1)<REF(C,2);--@贵派
ZVAR2:=(2*CLOSE+HIGH+LOW)/4;
ZVAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
ZVAR4:=LLV(LOW,5);
ZVAR5:=HHV(HIGH,4);
散户:=EMA((ZVAR2-ZVAR4)/(ZVAR5-ZVAR4)*100,4)*ZVAR3;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*ZVAR3;
XG1:=CROSS(散户,庄家) AND 散户<50 AND 29<散户;


VAR1C:=(HIGH-MIN(OPEN,CLOSE));
VAR2C:=(CLOSE-OPEN);
VAR3C:=(MIN(OPEN,CLOSE)-LOW);
VAR4C:=(HIGH-LOW);
VAR5C:=((VOL*VAR1C)/VAR4C);
VAR6C:=((VOL*VAR2C)/VAR4C);
VAR7C:=((VOL*VAR3C)/VAR4C);
VAR8C:=((VAR5C-VAR6C)-VAR7C);
VAR4:=MA(CLOSE,5);
VAR5:=MA(CLOSE,10);
VAR6:=MA(CLOSE,30);
VAR7:=MA(CLOSE,60);
VAR8:=EMA(COST(85),7);
VAR9:=EMA(COST(15),7);
VARA:=(SUM(((CLOSE*VOL)*100),4)/SUM((VOL*100),4));
VARB:=(INTPART((VARA*100))/100);
VARC:=(SUM(((CLOSE*VOL)*100),7)/SUM((VOL*100),7));
VARD:=(INTPART((VARC*100))/100);
VARE:=(SUM(((CLOSE*VOL)*100),28)/SUM((VOL*100),28));
VARF:=(INTPART((VARE*100))/100);
短线趋势:=(EMA(CLOSE,5)-EMA(CLOSE,10));
中线趋势:=EMA(短线趋势,9);
VAR10:=((0-((100*(HHV(CLOSE,5)-CLOSE))/(HHV(CLOSE,5)-LLV(LOW,5))))+100);
VAR11:=((0-((100*(HHV(CLOSE,10)-CLOSE))/(HHV(CLOSE,10)-LLV(LOW,10))))+100);
VAR12:=((0-((100*(HHV(CLOSE,20)-CLOSE))/(HHV(CLOSE,20)-LLV(LOW,20))))+100);
VAR13:=((0-((100*(HHV(CLOSE,30)-CLOSE))/(HHV(CLOSE,30)-LLV(LOW,30))))+100);
VAR14:=REF(中线趋势,1);
VAR15:=中线趋势;
VAR16:=(VAR15 - VAR14);
VAR17:=REF(短线趋势,1);
VAR18:=短线趋势;
VAR19:=(VAR18 - VAR17);
VAR1A:=OPEN;
VAR1B:=CLOSE;
XG1 AND (((((((VAR1A <= VAR4) AND (VAR1A <= VAR5)) AND (VAR1A <= VAR6))
AND (VAR1B >= VAR4)) AND (VAR1B >= VARF)) AND (VAR16 > 0)) AND (VAR19 > 0))
AND DYNAINFO(4)>0 AND REF(C,1)<REF(O,1) AND REF(C,1)<REF(C,2);--@葫芦岛15 老师你好 麻烦你帮写选股公式 { 牛启动  狙击  主升} 三个选股公式 谢谢你了 源码如下 DRAWKLINE(H,O,L,C);
HB:=COST(99.9);
LB:=COST(0.1);
B3:=(HB-LB)/50;
B31:=HB-B3;
B32:=HB-2*B3;
B33:=HB-3*B3;
B34:=HB-4*B3;
B35:=HB-5*B3;
B36:=HB-6*B3;
B37:=HB-7*B3;
B38:=HB-8*B3;
B39:=HB-9*B3;
B310:=HB-10*B3;
B311:=HB-11*B3;
B312:=HB-12*B3;
B313:=HB-13*B3;
B314:=HB-14*B3;
B315:=HB-15*B3;
B316:=HB-16*B3;
B317:=HB-17*B3;
B318:=HB-18*B3;
B319:=HB-19*B3;
B320:=HB-20*B3;
B321:=HB-21*B3;
B322:=HB-22*B3;
B323:=HB-23*B3;
B324:=HB-24*B3;
B325:=HB-25*B3;
B326:=HB-26*B3;
B327:=HB-27*B3;
B328:=HB-28*B3;
B329:=HB-29*B3;
B330:=HB-30*B3;
B331:=HB-31*B3;
B332:=HB-32*B3;
B333:=HB-33*B3;
B334:=HB-34*B3;
B335:=HB-35*B3;
B336:=HB-36*B3;
B337:=HB-37*B3;
B338:=HB-38*B3;
B339:=HB-39*B3;
B340:=HB-40*B3;
B341:=HB-41*B3;
B342:=HB-42*B3;
B343:=HB-43*B3;
B344:=HB-44*B3;
B345:=HB-45*B3;
B346:=HB-46*B3;
B347:=HB-47*B3;
B348:=HB-48*B3;
B349:=HB-49*B3;
A1:=WINNER(HB)*100-WINNER(B31)*100;
A2:=WINNER(B31)*100-WINNER(B32)*100;
A3:=WINNER(B32)*100-WINNER(B33)*100;
A4:=WINNER(B33)*100-WINNER(B34)*100;
A5:=WINNER(B34)*100-WINNER(B35)*100;
A6:=WINNER(B35)*100-WINNER(B36)*100;
A7:=WINNER(B36)*100-WINNER(B37)*100;
A8:=WINNER(B37)*100-WINNER(B38)*100;
A9:=WINNER(B38)*100-WINNER(B39)*100;
A10:=WINNER(B39)*100-WINNER(B310)*100;
A11:=WINNER(B310)*100-WINNER(B311)*100;
A12:=WINNER(B311)*100-WINNER(B312)*100;
A13:=WINNER(B312)*100-WINNER(B313)*100;
A14:=WINNER(B313)*100-WINNER(B314)*100;
A15:=WINNER(B314)*100-WINNER(B315)*100;
A16:=WINNER(B315)*100-WINNER(B316)*100;
A17:=WINNER(B316)*100-WINNER(B317)*100;
A18:=WINNER(B317)*100-WINNER(B318)*100;
A19:=WINNER(B318)*100-WINNER(B319)*100;
A20:=WINNER(B319)*100-WINNER(B320)*100;
A21:=WINNER(B320)*100-WINNER(B321)*100;
A22:=WINNER(B321)*100-WINNER(B322)*100;
A23:=WINNER(B322)*100-WINNER(B323)*100;
A24:=WINNER(B323)*100-WINNER(B324)*100;
A25:=WINNER(B324)*100-WINNER(B325)*100;
A26:=WINNER(B325)*100-WINNER(B326)*100;
A27:=WINNER(B326)*100-WINNER(B327)*100;
A28:=WINNER(B327)*100-WINNER(B328)*100;
A29:=WINNER(B328)*100-WINNER(B329)*100;
A30:=WINNER(B329)*100-WINNER(B330)*100;
A31:=WINNER(B330)*100-WINNER(B331)*100;
A32:=WINNER(B331)*100-WINNER(B332)*100;
A33:=WINNER(B332)*100-WINNER(B333)*100;
A34:=WINNER(B333)*100-WINNER(B334)*100;
A35:=WINNER(B334)*100-WINNER(B335)*100;
A36:=WINNER(B335)*100-WINNER(B336)*100;
A37:=WINNER(B336)*100-WINNER(B337)*100;
A38:=WINNER(B337)*100-WINNER(B338)*100;
A39:=WINNER(B338)*100-WINNER(B339)*100;
A40:=WINNER(B339)*100-WINNER(B340)*100;
A41:=WINNER(B340)*100-WINNER(B341)*100;
A42:=WINNER(B341)*100-WINNER(B342)*100;
A43:=WINNER(B342)*100-WINNER(B343)*100;
A44:=WINNER(B343)*100-WINNER(B344)*100;
A45:=WINNER(B344)*100-WINNER(B345)*100;
A46:=WINNER(B345)*100-WINNER(B346)*100;
A47:=WINNER(B346)*100-WINNER(B347)*100;
A48:=WINNER(B347)*100-WINNER(B348)*100;
A49:=WINNER(B348)*100-WINNER(B349)*100;
A50:=WINNER(B349)*100-WINNER(LB)*100;
STICKLINE(ISLASTBAR,HB ,HB ,A1*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B31 ,B31 ,A1*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B32 ,B32 ,A2*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B33 ,B33 ,A3*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B34 ,B34 ,A4*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B35 ,B35 ,A5*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B36 ,B36 ,A6*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B37 ,B37 ,A7*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B38 ,B38 ,A8*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B39 ,B39 ,A9*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B310 ,B310 ,A10*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B311 ,B311 ,A11*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B312 ,B312 ,A12*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B313 ,B313 ,A13*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B314 ,B314 ,A14*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B315 ,B315 ,A15*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B316 ,B316 ,A16*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B317 ,B317 ,A17*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B318 ,B318 ,A18*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B319 ,B319 ,A19*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B320 ,B320 ,A20*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B321 ,B321 ,A21*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B322 ,B322 ,A22*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B323 ,B323 ,A23*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B324 ,B324 ,A24*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B325 ,B325 ,A25*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B326 ,B326 ,A26*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B327 ,B327 ,A27*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B328 ,B328 ,A28*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B329 ,B329 ,A29*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B330 ,B330 ,A30*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B331 ,B331 ,A31*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B332 ,B332 ,A32*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B333 ,B333 ,A33*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B334 ,B334 ,A34*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B335 ,B335 ,A35*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B336 ,B336 ,A36*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B337 ,B337 ,A37*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B338 ,B338 ,A38*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B339 ,B339 ,A39*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B340 ,B340 ,A40*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B341 ,B341 ,A41*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B342 ,B342 ,A42*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B343 ,B343 ,A43*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B344 ,B344 ,A44*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B345 ,B345 ,A45*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B346 ,B346 ,A46*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B347 ,B347 ,A47*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,B348 ,B348 ,A48*15 ,0 ),COLOR666600;
STICKLINE(ISLASTBAR,LB ,LB ,A50*15 ,0 ),COLOR666600;
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;{涨停}
当前获利筹码:=IF(WINNER(CLOSE),WINNER(CLOSE)*100,0);
ZX2:=MIN(A1,MIN(A2,MIN(A3,MIN(A4,MIN(A5,MIN(A6,MIN(A7,MIN(A8,MIN(A9,MIN(A10,MIN(A11,MIN(A12,MIN(A13,MIN(A14,MIN(A15,MIN(A16,MIN(A17,MIN(A18,MIN(A19,MIN(A20,MIN(A21,MIN(A22,MIN(A23,MIN(A24,MIN(A25,MIN(A26,MIN(A27,MIN(A28,MIN(A29,MIN(A30,MIN(A31,MIN(A32,MIN(A33,MIN(A34,MIN(A35,MIN(A36,MIN(A37,MIN(A38,MIN(A39,MIN(A40,MIN(A41,MIN(A42,MIN(A43,MIN(A44,MIN(A45,MIN(A46,MIN(A47,MIN(A48,MIN(A49,A50)))))))))))))))))))))))))))))))))))))))))))))))));
筹码最低处:COST(ZX2),COLORMAGENTA;
RR:=COST(ZX2/100);
筹码最高处:=COST(100-ZX2),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,筹码最低处,'筹码最低价'),COLORMAGENTA;
ZX1:=MAX(A1,MAX(A2,MAX(A3,MAX(A4,MAX(A5,MAX(A6,MAX(A7,MAX(A8,MAX(A9,MAX(A10,MAX(A11,MAX(A12,MAX(A13,MAX(A14,MAX(A15,MAX(A16,MAX(A17,MAX(A18,MAX(A19,MAX(A20,MAX(A21,MAX(A22,MAX(A23,MAX(A24,MAX(A25,MAX(A26,MAX(A27,MAX(A28,MAX(A29,MAX(A30,MAX(A31,MAX(A32,MAX(A33,MAX(A34,MAX(A35,MAX(A36,MAX(A37,MAX(A38,MAX(A39,MAX(A40,MAX(A41,MAX(A42,MAX(A43,MAX(A44,MAX(A45,MAX(A46,MAX(A47,MAX(A48,MAX(A49,A50)))))))))))))))))))))))))))))))))))))))))))))))));
筹码最集中处:COST(ZX1),COLORRED,LINETHICK2;
筹码最集中处1:COST(100-ZX1),COLORYELLOW,LINETHICK2;
DRAWTEXT(ISLASTBAR,筹码最集中处,'筹码集中价'),COLORWHITE;

峰尖价:IF(ZX1=A1,B31,IF(ZX1=A2,B32,IF(ZX1=A3,B33,IF(ZX1=A4,B34,IF(ZX1=A5,B35,IF(ZX1=A6,B36,
IF(ZX1=A7,B37,IF(ZX1=A8,B38,IF(ZX1=A9,B39,IF(ZX1=A10,B310,IF(ZX1=A11,B311,IF(ZX1=A12,B312,IF(ZX1=A13,B313,
IF(ZX1=A14,B314,IF(ZX1=A15,B315,IF(ZX1=A16,B316,IF(ZX1=A17,B317,IF(ZX1=A18,B318,IF(ZX1=A19,B319,IF(ZX1=A20,B320,
IF(ZX1=A21,B321,IF(ZX1=A22,B322,IF(ZX1=A23,B323,IF(ZX1=A24,B324,IF(ZX1=A25,B325,IF(ZX1=A26,B326,IF(ZX1=A27,B327,
IF(ZX1=A28,B328,IF(ZX1=A29,B329,IF(ZX1=A30,B330,IF(ZX1=A31,B331,IF(ZX1=A32,B332,IF(ZX1=A33,B333,IF(ZX1=A34,B334,
IF(ZX1=A35,B335,IF(ZX1=A36,B336,IF(ZX1=A37,B337,IF(ZX1=A38,B338,IF(ZX1=A39,B339,IF(ZX1=A40,B340,IF(ZX1=A41,B341,
IF(ZX1=A42,B342,IF(ZX1=A43,B343,IF(ZX1=A44,B344,IF(ZX1=A45,B345,IF(ZX1=A46,B346,IF(ZX1=A47,B347,IF(ZX1=A48,B348,
IF(ZX1=A49,B349,0))))))))))))))))))))))))))))))))))))))))))))))))),LINETHICK2,COLORGREEN;
DRAWTEXT(ISLASTBAR,峰尖价,'峰尖价'),COLORWHITE;
STICKLINE(筹码最集中处>LOW AND 筹码最集中处<HIGH,筹码最集中处,MIN(MIN(OPEN,CLOSE),筹码最集中处),2,0),COLORMAGENTA;
STICKLINE(筹码最集中处>MIN(C,O) AND 筹码最集中处<MAX(C,O),筹码最集中处,MIN(OPEN,CLOSE),2,0),COLORMAGENTA;
STICKLINE(筹码最集中处>HIGH,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(筹码最集中处>HIGH,HIGH,LOW,0,0),COLORMAGENTA;
STICKLINE(筹码最集中处>LOW AND 筹码最集中处<HIGH,筹码最集中处,MIN(MIN(OPEN,CLOSE),筹码最集中处),1.5,0),COLORGREEN;
STICKLINE(筹码最集中处>MIN(C,O) AND 筹码最集中处<MAX(C,O),筹码最集中处,MIN(OPEN,CLOSE),2,0),COLORGREEN;
STICKLINE(筹码最集中处>HIGH,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(筹码最集中处>HIGH,HIGH,LOW,0,0),COLORGREEN;
DF2:=(C-REF(C,1))/REF(C,1)*100>5;
DF3:=(C-O)/O*100>4;
当天涨幅:(C-O)/O*100,NODRAW;
V型反转:=L<筹码最集中处 AND DF2;
V型反转2:=CROSS(C,筹码最集中处) AND DF2;
V型反转3:=L<筹码最集中处 AND DF3;
DRAWTEXT(V型反转,L*0.98,'↖狙击'),COLORCYAN;
DRAWTEXT(V型反转2,L*0.98,'↖狙击'),COLORCYAN;
DRAWTEXT(V型反转3,L*0.98,'↖狙击'),COLORCYAN;
顶部突破3:=REF(筹码最集中处1,2)>REF(筹码最集中处1,1) AND 筹码最集中处1>REF(筹码最集中处1,1);
顶部突破4:=REF(筹码最集中处1,2)=REF(筹码最集中处1,1) AND 筹码最集中处1>REF(筹码最集中处1,1);
DRAWTEXT(顶部突破3 OR 顶部突破4 ,L*0.99,'↖主升'),COLORYELLOW;
R1:=L<峰尖价 AND H>峰尖价 AND ZT;
R2:=CROSS(C,峰尖价) AND ZT;

DRAWTEXT(R1,L*0.98,'牛启动')COLORCYAN;
DRAWTEXT(R2,L*0.98,'牛启动')COLORCYAN;--@贵派
{选股1, 牛启动}
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
峰尖价:=IF(ZX1=A1,B31,IF(ZX1=A2,B32,IF(ZX1=A3,B33,IF(ZX1=A4,B34,IF(ZX1=A5,B35,IF(ZX1=A6,B36,
IF(ZX1=A7,B37,IF(ZX1=A8,B38,IF(ZX1=A9,B39,IF(ZX1=A10,B310,IF(ZX1=A11,B311,IF(ZX1=A12,B312,IF(ZX1=A13,B313,
IF(ZX1=A14,B314,IF(ZX1=A15,B315,IF(ZX1=A16,B316,IF(ZX1=A17,B317,IF(ZX1=A18,B318,IF(ZX1=A19,B319,IF(ZX1=A20,B320,
IF(ZX1=A21,B321,IF(ZX1=A22,B322,IF(ZX1=A23,B323,IF(ZX1=A24,B324,IF(ZX1=A25,B325,IF(ZX1=A26,B326,IF(ZX1=A27,B327,
IF(ZX1=A28,B328,IF(ZX1=A29,B329,IF(ZX1=A30,B330,IF(ZX1=A31,B331,IF(ZX1=A32,B332,IF(ZX1=A33,B333,IF(ZX1=A34,B334,
IF(ZX1=A35,B335,IF(ZX1=A36,B336,IF(ZX1=A37,B337,IF(ZX1=A38,B338,IF(ZX1=A39,B339,IF(ZX1=A40,B340,IF(ZX1=A41,B341,
IF(ZX1=A42,B342,IF(ZX1=A43,B343,IF(ZX1=A44,B344,IF(ZX1=A45,B345,IF(ZX1=A46,B346,IF(ZX1=A47,B347,IF(ZX1=A48,B348,
IF(ZX1=A49,B349,0)))))))))))))))))))))))))))))))))))))))))))))))));
R1:=L<峰尖价 AND H>峰尖价 AND ZT;
R2:=CROSS(C,峰尖价) AND ZT;
牛启动:R1 OR R2;--@贵派
{选股2, 狙击}
HB:=COST(99.9);LB:=COST(0.1);
B3:=(HB-LB)/50;
B31:=HB-B3;
B32:=HB-2*B3;
B33:=HB-3*B3;
B34:=HB-4*B3;
B35:=HB-5*B3;
B36:=HB-6*B3;
B37:=HB-7*B3;
B38:=HB-8*B3;
B39:=HB-9*B3;
B310:=HB-10*B3;
B311:=HB-11*B3;
B312:=HB-12*B3;
B313:=HB-13*B3;
B314:=HB-14*B3;
B315:=HB-15*B3;
B316:=HB-16*B3;
B317:=HB-17*B3;
B318:=HB-18*B3;
B319:=HB-19*B3;
B320:=HB-20*B3;
B321:=HB-21*B3;
B322:=HB-22*B3;
B323:=HB-23*B3;
B324:=HB-24*B3;
B325:=HB-25*B3;
B326:=HB-26*B3;
B327:=HB-27*B3;
B328:=HB-28*B3;
B329:=HB-29*B3;
B330:=HB-30*B3;
B331:=HB-31*B3;
B332:=HB-32*B3;
B333:=HB-33*B3;
B334:=HB-34*B3;
B335:=HB-35*B3;
B336:=HB-36*B3;
B337:=HB-37*B3;
B338:=HB-38*B3;
B339:=HB-39*B3;
B340:=HB-40*B3;
B341:=HB-41*B3;
B342:=HB-42*B3;
B343:=HB-43*B3;
B344:=HB-44*B3;
B345:=HB-45*B3;
B346:=HB-46*B3;
B347:=HB-47*B3;
B348:=HB-48*B3;
B349:=HB-49*B3;
A1:=WINNER(HB)*100-WINNER(B31)*100;
A2:=WINNER(B31)*100-WINNER(B32)*100;
A3:=WINNER(B32)*100-WINNER(B33)*100;
A4:=WINNER(B33)*100-WINNER(B34)*100;
A5:=WINNER(B34)*100-WINNER(B35)*100;
A6:=WINNER(B35)*100-WINNER(B36)*100;
A7:=WINNER(B36)*100-WINNER(B37)*100;
A8:=WINNER(B37)*100-WINNER(B38)*100;
A9:=WINNER(B38)*100-WINNER(B39)*100;
A10:=WINNER(B39)*100-WINNER(B310)*100;
A11:=WINNER(B310)*100-WINNER(B311)*100;
A12:=WINNER(B311)*100-WINNER(B312)*100;
A13:=WINNER(B312)*100-WINNER(B313)*100;
A14:=WINNER(B313)*100-WINNER(B314)*100;
A15:=WINNER(B314)*100-WINNER(B315)*100;
A16:=WINNER(B315)*100-WINNER(B316)*100;
A17:=WINNER(B316)*100-WINNER(B317)*100;
A18:=WINNER(B317)*100-WINNER(B318)*100;
A19:=WINNER(B318)*100-WINNER(B319)*100;
A20:=WINNER(B319)*100-WINNER(B320)*100;
A21:=WINNER(B320)*100-WINNER(B321)*100;
A22:=WINNER(B321)*100-WINNER(B322)*100;
A23:=WINNER(B322)*100-WINNER(B323)*100;
A24:=WINNER(B323)*100-WINNER(B324)*100;
A25:=WINNER(B324)*100-WINNER(B325)*100;
A26:=WINNER(B325)*100-WINNER(B326)*100;
A27:=WINNER(B326)*100-WINNER(B327)*100;
A28:=WINNER(B327)*100-WINNER(B328)*100;
A29:=WINNER(B328)*100-WINNER(B329)*100;
A30:=WINNER(B329)*100-WINNER(B330)*100;
A31:=WINNER(B330)*100-WINNER(B331)*100;
A32:=WINNER(B331)*100-WINNER(B332)*100;
A33:=WINNER(B332)*100-WINNER(B333)*100;
A34:=WINNER(B333)*100-WINNER(B334)*100;
A35:=WINNER(B334)*100-WINNER(B335)*100;
A36:=WINNER(B335)*100-WINNER(B336)*100;
A37:=WINNER(B336)*100-WINNER(B337)*100;
A38:=WINNER(B337)*100-WINNER(B338)*100;
A39:=WINNER(B338)*100-WINNER(B339)*100;
A40:=WINNER(B339)*100-WINNER(B340)*100;
A41:=WINNER(B340)*100-WINNER(B341)*100;
A42:=WINNER(B341)*100-WINNER(B342)*100;
A43:=WINNER(B342)*100-WINNER(B343)*100;
A44:=WINNER(B343)*100-WINNER(B344)*100;
A45:=WINNER(B344)*100-WINNER(B345)*100;
A46:=WINNER(B345)*100-WINNER(B346)*100;
A47:=WINNER(B346)*100-WINNER(B347)*100;
A48:=WINNER(B347)*100-WINNER(B348)*100;
A49:=WINNER(B348)*100-WINNER(B349)*100;
A50:=WINNER(B349)*100-WINNER(LB)*100;
ZX1:=MAX(A1,MAX(A2,MAX(A3,MAX(A4,MAX(A5,MAX(A6,MAX(A7,MAX(A8,MAX(A9,MAX(A10,MAX(A11,
MAX(A12,MAX(A13,MAX(A14,MAX(A15,MAX(A16,MAX(A17,MAX(A18,MAX(A19,MAX(A20,MAX(A21,
MAX(A22,MAX(A23,MAX(A24,MAX(A25,MAX(A26,MAX(A27,MAX(A28,MAX(A29,MAX(A30,MAX(A31,
MAX(A32,MAX(A33,MAX(A34,MAX(A35,MAX(A36,MAX(A37,MAX(A38,MAX(A39,MAX(A40,MAX(A41,
MAX(A42,MAX(A43,MAX(A44,MAX(A45,MAX(A46,MAX(A47,MAX(A48,MAX(A49,A50)))))))))))))))))))))))))))))))))))))))))))))))));
筹码最集中处:=COST(ZX1);
DF2:=(C-REF(C,1))/REF(C,1)*100>5;
DF3:=(C-O)/O*100>4;
V型反转:=L<筹码最集中处 AND DF2;
V型反转2:=CROSS(C,筹码最集中处) AND DF2;
V型反转3:=L<筹码最集中处 AND DF3;
狙击:V型反转 OR V型反转2 OR V型反转3;--@贵派
{选股3, 主升}
HB:=COST(99.9);LB:=COST(0.1);
B3:=(HB-LB)/50;
B31:=HB-B3;
B32:=HB-2*B3;
B33:=HB-3*B3;
B34:=HB-4*B3;
B35:=HB-5*B3;
B36:=HB-6*B3;
B37:=HB-7*B3;
B38:=HB-8*B3;
B39:=HB-9*B3;
B310:=HB-10*B3;
B311:=HB-11*B3;
B312:=HB-12*B3;
B313:=HB-13*B3;
B314:=HB-14*B3;
B315:=HB-15*B3;
B316:=HB-16*B3;
B317:=HB-17*B3;
B318:=HB-18*B3;
B319:=HB-19*B3;
B320:=HB-20*B3;
B321:=HB-21*B3;
B322:=HB-22*B3;
B323:=HB-23*B3;
B324:=HB-24*B3;
B325:=HB-25*B3;
B326:=HB-26*B3;
B327:=HB-27*B3;
B328:=HB-28*B3;
B329:=HB-29*B3;
B330:=HB-30*B3;
B331:=HB-31*B3;
B332:=HB-32*B3;
B333:=HB-33*B3;
B334:=HB-34*B3;
B335:=HB-35*B3;
B336:=HB-36*B3;
B337:=HB-37*B3;
B338:=HB-38*B3;
B339:=HB-39*B3;
B340:=HB-40*B3;
B341:=HB-41*B3;
B342:=HB-42*B3;
B343:=HB-43*B3;
B344:=HB-44*B3;
B345:=HB-45*B3;
B346:=HB-46*B3;
B347:=HB-47*B3;
B348:=HB-48*B3;
B349:=HB-49*B3;
A1:=WINNER(HB)*100-WINNER(B31)*100;
A2:=WINNER(B31)*100-WINNER(B32)*100;
A3:=WINNER(B32)*100-WINNER(B33)*100;
A4:=WINNER(B33)*100-WINNER(B34)*100;
A5:=WINNER(B34)*100-WINNER(B35)*100;
A6:=WINNER(B35)*100-WINNER(B36)*100;
A7:=WINNER(B36)*100-WINNER(B37)*100;
A8:=WINNER(B37)*100-WINNER(B38)*100;
A9:=WINNER(B38)*100-WINNER(B39)*100;
A10:=WINNER(B39)*100-WINNER(B310)*100;
A11:=WINNER(B310)*100-WINNER(B311)*100;
A12:=WINNER(B311)*100-WINNER(B312)*100;
A13:=WINNER(B312)*100-WINNER(B313)*100;
A14:=WINNER(B313)*100-WINNER(B314)*100;
A15:=WINNER(B314)*100-WINNER(B315)*100;
A16:=WINNER(B315)*100-WINNER(B316)*100;
A17:=WINNER(B316)*100-WINNER(B317)*100;
A18:=WINNER(B317)*100-WINNER(B318)*100;
A19:=WINNER(B318)*100-WINNER(B319)*100;
A20:=WINNER(B319)*100-WINNER(B320)*100;
A21:=WINNER(B320)*100-WINNER(B321)*100;
A22:=WINNER(B321)*100-WINNER(B322)*100;
A23:=WINNER(B322)*100-WINNER(B323)*100;
A24:=WINNER(B323)*100-WINNER(B324)*100;
A25:=WINNER(B324)*100-WINNER(B325)*100;
A26:=WINNER(B325)*100-WINNER(B326)*100;
A27:=WINNER(B326)*100-WINNER(B327)*100;
A28:=WINNER(B327)*100-WINNER(B328)*100;
A29:=WINNER(B328)*100-WINNER(B329)*100;
A30:=WINNER(B329)*100-WINNER(B330)*100;
A31:=WINNER(B330)*100-WINNER(B331)*100;
A32:=WINNER(B331)*100-WINNER(B332)*100;
A33:=WINNER(B332)*100-WINNER(B333)*100;
A34:=WINNER(B333)*100-WINNER(B334)*100;
A35:=WINNER(B334)*100-WINNER(B335)*100;
A36:=WINNER(B335)*100-WINNER(B336)*100;
A37:=WINNER(B336)*100-WINNER(B337)*100;
A38:=WINNER(B337)*100-WINNER(B338)*100;
A39:=WINNER(B338)*100-WINNER(B339)*100;
A40:=WINNER(B339)*100-WINNER(B340)*100;
A41:=WINNER(B340)*100-WINNER(B341)*100;
A42:=WINNER(B341)*100-WINNER(B342)*100;
A43:=WINNER(B342)*100-WINNER(B343)*100;
A44:=WINNER(B343)*100-WINNER(B344)*100;
A45:=WINNER(B344)*100-WINNER(B345)*100;
A46:=WINNER(B345)*100-WINNER(B346)*100;
A47:=WINNER(B346)*100-WINNER(B347)*100;
A48:=WINNER(B347)*100-WINNER(B348)*100;
A49:=WINNER(B348)*100-WINNER(B349)*100;
A50:=WINNER(B349)*100-WINNER(LB)*100;
ZX1:=MAX(A1,MAX(A2,MAX(A3,MAX(A4,MAX(A5,MAX(A6,MAX(A7,MAX(A8,MAX(A9,MAX(A10,MAX(A11,
MAX(A12,MAX(A13,MAX(A14,MAX(A15,MAX(A16,MAX(A17,MAX(A18,MAX(A19,MAX(A20,MAX(A21,
MAX(A22,MAX(A23,MAX(A24,MAX(A25,MAX(A26,MAX(A27,MAX(A28,MAX(A29,MAX(A30,MAX(A31,
MAX(A32,MAX(A33,MAX(A34,MAX(A35,MAX(A36,MAX(A37,MAX(A38,MAX(A39,MAX(A40,MAX(A41,
MAX(A42,MAX(A43,MAX(A44,MAX(A45,MAX(A46,MAX(A47,MAX(A48,MAX(A49,A50)))))))))))))))))))))))))))))))))))))))))))))))));
筹码最集中处1:=COST(100-ZX1);
顶部突破3:=REF(筹码最集中处1,2)>REF(筹码最集中处1,1) AND 筹码最集中处1>REF(筹码最集中处1,1);
顶部突破4:=REF(筹码最集中处1,2)=REF(筹码最集中处1,1) AND 筹码最集中处1>REF(筹码最集中处1,1);
主升:顶部突破3 OR 顶部突破4;--@贵派
{选股1, 牛启动 (替换上面的)}
HB:=COST(99.9);LB:=COST(0.1);
B3:=(HB-LB)/50;
B31:=HB-B3;
B32:=HB-2*B3;
B33:=HB-3*B3;
B34:=HB-4*B3;
B35:=HB-5*B3;
B36:=HB-6*B3;
B37:=HB-7*B3;
B38:=HB-8*B3;
B39:=HB-9*B3;
B310:=HB-10*B3;
B311:=HB-11*B3;
B312:=HB-12*B3;
B313:=HB-13*B3;
B314:=HB-14*B3;
B315:=HB-15*B3;
B316:=HB-16*B3;
B317:=HB-17*B3;
B318:=HB-18*B3;
B319:=HB-19*B3;
B320:=HB-20*B3;
B321:=HB-21*B3;
B322:=HB-22*B3;
B323:=HB-23*B3;
B324:=HB-24*B3;
B325:=HB-25*B3;
B326:=HB-26*B3;
B327:=HB-27*B3;
B328:=HB-28*B3;
B329:=HB-29*B3;
B330:=HB-30*B3;
B331:=HB-31*B3;
B332:=HB-32*B3;
B333:=HB-33*B3;
B334:=HB-34*B3;
B335:=HB-35*B3;
B336:=HB-36*B3;
B337:=HB-37*B3;
B338:=HB-38*B3;
B339:=HB-39*B3;
B340:=HB-40*B3;
B341:=HB-41*B3;
B342:=HB-42*B3;
B343:=HB-43*B3;
B344:=HB-44*B3;
B345:=HB-45*B3;
B346:=HB-46*B3;
B347:=HB-47*B3;
B348:=HB-48*B3;
B349:=HB-49*B3;
A1:=WINNER(HB)*100-WINNER(B31)*100;
A2:=WINNER(B31)*100-WINNER(B32)*100;
A3:=WINNER(B32)*100-WINNER(B33)*100;
A4:=WINNER(B33)*100-WINNER(B34)*100;
A5:=WINNER(B34)*100-WINNER(B35)*100;
A6:=WINNER(B35)*100-WINNER(B36)*100;
A7:=WINNER(B36)*100-WINNER(B37)*100;
A8:=WINNER(B37)*100-WINNER(B38)*100;
A9:=WINNER(B38)*100-WINNER(B39)*100;
A10:=WINNER(B39)*100-WINNER(B310)*100;
A11:=WINNER(B310)*100-WINNER(B311)*100;
A12:=WINNER(B311)*100-WINNER(B312)*100;
A13:=WINNER(B312)*100-WINNER(B313)*100;
A14:=WINNER(B313)*100-WINNER(B314)*100;
A15:=WINNER(B314)*100-WINNER(B315)*100;
A16:=WINNER(B315)*100-WINNER(B316)*100;
A17:=WINNER(B316)*100-WINNER(B317)*100;
A18:=WINNER(B317)*100-WINNER(B318)*100;
A19:=WINNER(B318)*100-WINNER(B319)*100;
A20:=WINNER(B319)*100-WINNER(B320)*100;
A21:=WINNER(B320)*100-WINNER(B321)*100;
A22:=WINNER(B321)*100-WINNER(B322)*100;
A23:=WINNER(B322)*100-WINNER(B323)*100;
A24:=WINNER(B323)*100-WINNER(B324)*100;
A25:=WINNER(B324)*100-WINNER(B325)*100;
A26:=WINNER(B325)*100-WINNER(B326)*100;
A27:=WINNER(B326)*100-WINNER(B327)*100;
A28:=WINNER(B327)*100-WINNER(B328)*100;
A29:=WINNER(B328)*100-WINNER(B329)*100;
A30:=WINNER(B329)*100-WINNER(B330)*100;
A31:=WINNER(B330)*100-WINNER(B331)*100;
A32:=WINNER(B331)*100-WINNER(B332)*100;
A33:=WINNER(B332)*100-WINNER(B333)*100;
A34:=WINNER(B333)*100-WINNER(B334)*100;
A35:=WINNER(B334)*100-WINNER(B335)*100;
A36:=WINNER(B335)*100-WINNER(B336)*100;
A37:=WINNER(B336)*100-WINNER(B337)*100;
A38:=WINNER(B337)*100-WINNER(B338)*100;
A39:=WINNER(B338)*100-WINNER(B339)*100;
A40:=WINNER(B339)*100-WINNER(B340)*100;
A41:=WINNER(B340)*100-WINNER(B341)*100;
A42:=WINNER(B341)*100-WINNER(B342)*100;
A43:=WINNER(B342)*100-WINNER(B343)*100;
A44:=WINNER(B343)*100-WINNER(B344)*100;
A45:=WINNER(B344)*100-WINNER(B345)*100;
A46:=WINNER(B345)*100-WINNER(B346)*100;
A47:=WINNER(B346)*100-WINNER(B347)*100;
A48:=WINNER(B347)*100-WINNER(B348)*100;
A49:=WINNER(B348)*100-WINNER(B349)*100;
A50:=WINNER(B349)*100-WINNER(LB)*100;
ZX1:=MAX(A1,MAX(A2,MAX(A3,MAX(A4,MAX(A5,MAX(A6,MAX(A7,MAX(A8,MAX(A9,MAX(A10,MAX(A11,
MAX(A12,MAX(A13,MAX(A14,MAX(A15,MAX(A16,MAX(A17,MAX(A18,MAX(A19,MAX(A20,MAX(A21,
MAX(A22,MAX(A23,MAX(A24,MAX(A25,MAX(A26,MAX(A27,MAX(A28,MAX(A29,MAX(A30,MAX(A31,
MAX(A32,MAX(A33,MAX(A34,MAX(A35,MAX(A36,MAX(A37,MAX(A38,MAX(A39,MAX(A40,MAX(A41,
MAX(A42,MAX(A43,MAX(A44,MAX(A45,MAX(A46,MAX(A47,MAX(A48,MAX(A49,A50)))))))))))))))))))))))))))))))))))))))))))))))));
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
峰尖价:=IF(ZX1=A1,B31,IF(ZX1=A2,B32,IF(ZX1=A3,B33,IF(ZX1=A4,B34,IF(ZX1=A5,B35,IF(ZX1=A6,B36,
IF(ZX1=A7,B37,IF(ZX1=A8,B38,IF(ZX1=A9,B39,IF(ZX1=A10,B310,IF(ZX1=A11,B311,IF(ZX1=A12,B312,IF(ZX1=A13,B313,
IF(ZX1=A14,B314,IF(ZX1=A15,B315,IF(ZX1=A16,B316,IF(ZX1=A17,B317,IF(ZX1=A18,B318,IF(ZX1=A19,B319,IF(ZX1=A20,B320,
IF(ZX1=A21,B321,IF(ZX1=A22,B322,IF(ZX1=A23,B323,IF(ZX1=A24,B324,IF(ZX1=A25,B325,IF(ZX1=A26,B326,IF(ZX1=A27,B327,
IF(ZX1=A28,B328,IF(ZX1=A29,B329,IF(ZX1=A30,B330,IF(ZX1=A31,B331,IF(ZX1=A32,B332,IF(ZX1=A33,B333,IF(ZX1=A34,B334,
IF(ZX1=A35,B335,IF(ZX1=A36,B336,IF(ZX1=A37,B337,IF(ZX1=A38,B338,IF(ZX1=A39,B339,IF(ZX1=A40,B340,IF(ZX1=A41,B341,
IF(ZX1=A42,B342,IF(ZX1=A43,B343,IF(ZX1=A44,B344,IF(ZX1=A45,B345,IF(ZX1=A46,B346,IF(ZX1=A47,B347,IF(ZX1=A48,B348,
IF(ZX1=A49,B349,0)))))))))))))))))))))))))))))))))))))))))))))))));
R1:=L<峰尖价 AND H>峰尖价 AND ZT;
R2:=CROSS(C,峰尖价) AND ZT;
牛启动:R1 OR R2;--@葫芦岛15 老师 这个指标有实用性吗--@葫芦岛15 老师你好 麻烦你帮写选股公式( 买 ,大资金活动)源码如下   开关:=1;
TJ:=REFX(CLOSE,6)>0;
VAR1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
指标:IF(TJ+开关,EMA(EMA(VAR1,5),5)*3,0), COLORSTICK;
VARC:=(ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2))
AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3));
VARD:=(ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2))
AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3));
零轴:0,COLORYELLOW;
DRAWTEXT((VARC=1 AND (TJ+开关)),2,'买'),COLORRED,LINETHICK2;
STICKLINE((VARC=1 AND (TJ+开关)),(-14),0,4,0),COLORRED,LINETHICK2;
DRAWTEXT((VARD=1 AND (TJ+开关)),-2,'卖'),COLORGREEN,LINETHICK2;
STICKLINE((VARD=1 AND (TJ+开关)),14,0,4,0),COLORGREEN,LINETHICK2;
VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR2:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR3:=VARF<REF(VAR2,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(VAR3 AND COUNT(VAR3,30)=1 AND (TJ+开关),12,'大资金活动'),LINETHICK1,COLOR00FFFF;
STICKLINE(VAR3 AND COUNT(VAR3,30)=1 AND (TJ+开关),0,10,5,0),COLORFF00FF;--@贵派
{1. 买 选股}
开关:=1;
TJ:=REFX(C,6)>0;
VARC:=(ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3));
买:VARC=1 AND (TJ+开关);

{2. 大资金活动 选股}
开关:=1;
TJ:=REFX(C,6)>0;
VARF:=100-3*SMA((C-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1)+2*SMA(SMA((C-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);
VAR2:=100-3*SMA((O-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1)+2*SMA(SMA((O-LLV(L,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);
VAR3:=VARF<REF(VAR2,1) AND V>REF(V,1) AND C>REF(C,1);
大资金活动:VAR3 AND COUNT(VAR3,30)=1 AND (TJ+开关);


讨论:
1. 开关=1的设置无意义.
2.源码中的 ”REFX(C,6)>0“ 是说6日后的收盘价>0. 那今天怎能选到股票?--@葫芦岛15老师你好 麻烦你帮写选股公式( 买 入)源码如下  VARJ:=(3*CLOSE+LOW+HIGH+OPEN)/6;
卖出:XMA(VARJ,20)*1.08,COLOR00FF00,LINETHICK2;
买入:XMA(VARJ,32)*0.9,COLORFF00FF,LINETHICK2;
幅度:=100*(卖出-买入)/买入,COLOR00FF00,NODRAW;
HHJSJDA:=(CLOSE+OPEN+LOW+HIGH)/4;
主力成本线:(20*HHJSJDA+19*REF(HHJSJDA,1)+18*REF(HHJSJDA,2)+17*REF(HHJSJDA,3)+16*REF(HHJSJDA,4)+15*REF(HHJSJDA,5)+14*REF(HHJSJDA,6)
+13*REF(HHJSJDA,7)+12*REF(HHJSJDA,8)+11*REF(HHJSJDA,9)+10*REF(HHJSJDA,10)+9*REF(HHJSJDA,11)+8*REF(HHJSJDA,12)
+7*REF(HHJSJDA,13)+6*REF(HHJSJDA,14)+5*REF(HHJSJDA,15)+4*REF(HHJSJDA,16)+3*REF(HHJSJDA,17)+2*REF(HHJSJDA,18)+
REF(HHJSJDA,20))/210,COLORYELLOW;
止损线:MA(主力成本线,10),COLORFF00FF;
BIAS主力成本:(CLOSE-主力成本线)/主力成本线*100,COLORWHITE,NODRAW;
MA30:MA(CLOSE,30),COLOR0099FF,LINETHICK5;
BIAS30:(CLOSE-MA30)/MA30*100,COLORYELLOW,NODRAW;
EMA60:EMA(VARJ,60),COLOR00FF00;
EMA120:EMA(VARJ,120),COLORFFFF00;
均价:(HIGH+LOW+OPEN+3*CLOSE)/6,COLOR0099FF,NODRAW;
RPY2:(CLOSE-LLV(LOW,500))/(HHV(HIGH,500)-LLV(LOW,500))*100,COLORYELLOW,NODRAW;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
B1:IF(买1>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLOR0099FF;
B2:IF(买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
DRAWTEXT(买1>0 OR 买2>0,LOW*0.97,'买入'),COLORRED;
S1:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLOR00FF00;
DRAWTEXT(卖1>0,HIGH*1.02,'卖出'),COLOR00FF00;
S2:IF(PEAKBARS(3,16,1)=0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORRED;--@贵派  @葫芦岛15 老师你好我是新手  麻烦你将两个选股公式合并预警 辛苦你了 源码如下  RSV14:=(CLOSE - LLV(LOW,5))/(HHV(HIGH,5) - LLV(LOW,5))-0.5;
K14:=EMA(RSV14,3);
D14:=EMA(K14,3);
J14:=3*K14-2*D14;
KDJXG:=REF(COUNT(J14<REF(J14,1),5)>=3,1) AND REF(J14,1)<-0.4 AND J14>REF(J14,1);
手指选股:FILTER(KDJXG,3);

VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),0),COLOR0000FF;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),0),COLOR00FF00;
短牛:(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
去除停牌:=DYNAINFO(4)>0; {去除停牌}
去ST股:=IF(NAMELIKE('S')OR NAMELIKE('*') ,0,1);{去掉*ST和ST};
 莫易坚:   2016-10-2 11:09
   烦请老师将这个“仙人指路[副图]”(箭头处)改为通达信版的选股公式。谢谢。
仙人指路[副图]
STICKLINE(C<=O,H,L,0,0),COLORGREEN;
STICKLINE(C<=O,C,O,8,0),COLOR007700;
STICKLINE(C<=O,C,O,7,0),COLOR008E00;
STICKLINE(C<=O,C,O,6,0),COLOR009900;
STICKLINE(C<=O,C,O,5,0),COLOR00A600;
STICKLINE(C<=O,C,O,4,0),COLOR00B500;
STICKLINE(C<=O,C,O,3,0),COLOR00C600;
STICKLINE(C<=O,C,O,2,0),COLOR00D500;
STICKLINE(C<=O,C,O,1,0),COLOR00E600;
STICKLINE(C>O,H,L,0,0),COLOR106FFF;
STICKLINE(C>O,C,O,8,0),COLOR000084;
STICKLINE(C>O,C,O,7,0),COLOR000095;
STICKLINE(C>O,C,O,6,0),COLOR0000A2;
STICKLINE(C>O,C,O,5,0),COLOR0000B3;
STICKLINE(C>O,C,O,4,0),COLOR0000C8;
STICKLINE(C>O,C,O,3,0),COLOR0000D7;
STICKLINE(C>O,C,O,2,0),COLOR0000EA;
STICKLINE(C>O,C,O,1,0),COLOR0000FF;
买线:EMA(C,3),COLORWHITE;
卖线:EMA(SLOPE(C,21)*20+C,55),COLORFF00FF;
买卖差:=买线-卖线;
STICKLINE(买卖差>=0,(买线-买卖差*0.05),(买线-买卖差*0.15),2,0) ,COLOR00FFFF;
STICKLINE(买卖差>=0,(买线-买卖差*0.2),(买线-买卖差*0.35),2,0) ,COLOR00CCFF;
STICKLINE(买卖差>=0,(买线-买卖差*0.4),(买线-买卖差*0.55),2,0) ,COLOR0099FF;
STICKLINE(买卖差>=0,(买线-买卖差*0.6),(买线-买卖差*0.75),2,0) ,COLOR0066FF;
STICKLINE(买卖差>=0,(买线-买卖差*0.8),(买线-买卖差*0.95),2,0) ,COLOR0000CC;
STICKLINE(买卖差<0,(卖线+买卖差*0.05),(卖线+买卖差*0.15),2,0) ,COLOR006600;
STICKLINE(买卖差<0,(卖线+买卖差*0.2),(卖线+买卖差*0.35),2,0) ,COLOR009900;
STICKLINE(买卖差<0,(卖线+买卖差*0.4),(卖线+买卖差*0.55),2,0) ,COLOR00CC00;
STICKLINE(买卖差<0,(卖线+买卖差*0.6),(卖线+买卖差*0.75),2,0) ,COLOR00FF00;
STICKLINE(买卖差<0,(卖线+买卖差*0.8),(卖线+买卖差*0.95),2,0) ,COLOR66FF00;
多:=EMA(C,3),COLORYELLOW;
空:=EMA(C,5),COLOR00FF00;
均衡:=EMA(空,5),COLORWHITE,;
VARF1:=COUNT(CROSS(多,均衡),2)=1;
VARF2:=COUNT(CROSS(空,均衡),2)=1;
ZAI:=FILTER(VARF1 AND VARF2,2);
DRAWTEXT(ZAI,买线*0.95,'↖'),COLORYELLOW;
VV2:=REF(CLOSE,1);
VV3:=SMA((CLOSE-VV2),6,1)/SMA(ABS(CLOSE-VV2),6,1)*100;
VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;
VARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
VARB:=EMA(0.667*REF(VARA,1)+0.333*VARA,5);
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
{DRAWTEXT(CROSS(82,VARR1),买线*1.15,'短空↓'),COLORYELLOW;}
VAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR2:=REF(VAR1,1);
VAR3:=SMA(MAX(VAR1-VAR2,0),10,1)/SMA(ABS(VAR1-VAR2),10,1)*100;
HY3:=IF(COUNT(VAR3<20,5)>=1 AND COUNT(VAR1=LLV(VAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);

[ 本帖最后由 任刚 于 2016-10-3 09:11 编辑 ]

 股票专家荐股少而精.成功率达95%免费个股咨询点这里

 想了解手头持有个股接下来的走势个股论坛-股票吧点击这里

烦请老师将这个“仙人指路[副图]”改为通达信版的选股公式(已解答:葫芦岛15)..更多详情请加腾飞涨停微信:gupiao139

相关热词搜索:通达信 选股公式 选股指标

上一篇:请哪位老师把这个指标出现共振做个选股公式(已解答:愤怒的猪哥)
下一篇:求助:通达信选股公式改大智慧预警(已解答:愤怒的猪哥)

本栏点击总排行
分享到: 收藏
短信荐股回顾
邮件传真荐股回顾
整网点击月排行
整网点击排行