自用狙击涨停板的主图和预警公式(贴图、源码、通达信)
2016-03-01 08:21:00   来源:股票壹网   评论:0 点击:

自用狙击涨停板的主图和预警公式(贴图、源码、通达信) { 至简主图 } 跳空率:(O-REF(C,1)) REF(C,1)*100,COLORMAGENTA,NODRAW; 今板:=DYNAINFO(3)*1 1,DOTLINE,COLORYELLOW,NODRAW; 转折:=CROSS(ZIG(3,5),RE
  自用狙击涨停板的主图和预警公式(贴图、源码、通达信)
{ 至简主图 }

跳空率:(O-REF(C,1))/REF(C,1)*100,COLORMAGENTA,NODRAW;
今板:=DYNAINFO(3)*1.1,DOTLINE,COLORYELLOW,NODRAW;
转折:=CROSS(ZIG(3,5),REF(ZIG(3,5),1));
反转折:=CROSS(REF(ZIG(3,5),1),ZIG(3,5));
低1:=REF(LLV(L,150),3);
标底:=REFDATE(低1,DATE)*0.9;

突破:=REF(EMA(C,14),1),DOTLINE;
A1X:=(EMA(C,10)-突破)/突破*100;
多方:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),DRAWNULL),DOTLINE,COLORRED,LINETHICK1;
空方:=IF(A1X<0,REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1),DRAWNULL),DOTLINE,COLORGREEN,LINETHICK1;

GZ:=(LOW+HIGH+CLOSE)/3;
五日:=EMA(GZ,5),COLORWHITE,LINETHICK1;
十日:=EMA(五日,10),COLORYELLOW,LINETHICK1;

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26),NODRAW;
DEA:=EMA(DIFF,9),NODRAW;
资金:=(DIFF-DEA)*4,NODRAW;

线角:=ATAN((C/REF(C,1)-1)*100)*180/3.1416,NODRAW;

乖1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+100;
乖2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100+100;
乖3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+100;
角1:=ATAN((乖1/REF(乖1,1)-1)*100)*180/3.1416,NODRAW;
角2:=ATAN((乖2/REF(乖2,1)-1)*100)*180/3.1416,NODRAW;
角3:=ATAN((乖3/REF(乖3,1)-1)*100)*180/3.1416,NODRAW;
乖离角:=角1>=70 AND 角2>=70 AND 角3>=70;

Q1:=-100*(HHV(H,6)-C)/(HHV(HIGH,6)-LLV(L,6))+100,NODRAW;
Q上:=Q1>=REF(Q1,1);
Q下:=Q1<REF(Q1,1);
TJ01:=Q1>=70;

BB:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:=IF(MA(CLOSE,17)<BB,BB,MA(CLOSE,17));
操作线:=分水岭-(EMA(C,3)-分水岭);
PM:=EMA(GZ,5);
TJ02:=操作线<=分水岭 AND 操作线<=REF(操作线,1);

TJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买盘:=IF(CLOSE>OPEN,TJ*(HIGH-LOW),IF(CLOSE<OPEN,TJ*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
卖盘:=IF(CLOSE>OPEN,TJ*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,TJ*(HIGH-LOW),VOL/2));
正成交量比%:=买盘/VOL*100,COLORWHITE,NODRAW;
负成交量比%:=卖盘/VOL*100,COLORWHITE,NODRAW;
成交量比差:=(正成交量比%-负成交量比%),COLORWHITE,NODRAW;
量增:=成交量比差>=REF(成交量比差,1);
量减:=成交量比差<REF(成交量比差,1);
买增:=买盘>=REF(买盘,1);
卖减:=卖盘<=REF(卖盘,1);
增量:=正成交量比%>=70 ;{AND REF(成交量比差,1)<=60}

B1:=ZIG(3,5)*20;
B1红:=B1>REF(B1,1);
涨幅:=(C-REF(C,1))/REF(C,1)*100,NODRAW;
涨幅度:(C-REF(多方,1))/REF(多方,1)*100,NODRAW;
剔跳空:=(O-REF(C,1))/REF(C,1)*100<=6;
N日均涨幅:(REF(C,1)-REF(C,2))/REF(C,2)*100,COLORYELLOW,NODRAW;
涨幅限:=N日均涨幅<=7.5;
昨涨幅:=REF(涨幅,1);

{条件}佛光乍现:=线角>=70 AND 乖离角 AND TJ01 AND TJ02 AND 增量 AND 剔跳空 AND B1红;

{ ·········································}
DRAWRECTREL(0,0,999,990,RGB(108,108,108));
DRAWRECTREL(0,0,999,100,RGB(90,0,0));

DRAWBAND(空方,RGB(18,18,68),突破,RGB(0,0,255));
DRAWBAND(突破,RGB(58,8,8),多方,RGB(0,0,255));

DRAWBAND(五日,RGB(250,98,0),十日,RGB(8,188,8));
STICKLINE(ISLASTBAR,DYNAINFO(3),DYNAINFO(3)*1.1,2.8,-1),COLORWHITE;

转折线:=REF(L,BARSLAST(转折)),CROSSDOT,COLORWHITE,LINETHICK2;
CCC:=STICKLINE(转折,REFDATE(低1,DATE)*0.9,L,0.1,-1),COLORGREEN;
BBB:=STICKLINE(转折线>REF(转折线,1),REFDATE(低1,DATE)*0.9,L,0.1,-1),COLORRED;

DRAWKLINE(H,O,L,C);

STICKLINE(佛光乍现 AND C>=REF(C,1),H,L,0,0),COLOR0099FF;
STICKLINE(佛光乍现 AND C>=REF(C,1),C,O,3.2,0),COLOR0000AA;
STICKLINE(佛光乍现 AND C>=REF(C,1),C,O,2.7,0),COLOR0000DD;
STICKLINE(佛光乍现 AND C>=REF(C,1),C,O,2.1,0),COLOR0022FF;
STICKLINE(佛光乍现 AND C>=REF(C,1),C,O,1.5,0),COLOR0066FF;
STICKLINE(佛光乍现 AND C>=REF(C,1),C,O,0.9,0),COLOR0099FF;
STICKLINE(佛光乍现 AND C>=REF(C,1),C,O,0.3,0),COLOR00DDFF;

STICKLINE(DIFF>0,标底,标底+DIFF*2,2.6,0),COLORRED;
STICKLINE(DIFF<0,标底+DIFF*2,标底+DEA*2,2.6,0),COLORLIGREEN;
STICKLINE(DEA<0,标底,标底+DEA*2,2.6,0),COLORLIBLUE;
STICKLINE(DEA>0,标底,标底+DEA*2,2.6,0),COLORBLUE;
IF(C,标底+DEA*2,DRAWNULL),COLORWHITE,LINETHICK1;
IF(C,标底+DIFF*2,DRAWNULL),COLORFFF000,LINETHICK1;
IF(DIFF>=REF(DIFF,1),标底+DIFF*2,DRAWNULL),COLORRED,LINETHICK2;

{STICKLINE((标底+资金)>标底 AND (标底+资金)<=REF(标底+资金,1),标底,标底+资金,0.8,0),COLORLIBLUE;
STICKLINE((标底+资金)>标底 AND (标底+资金)>REF(标底+资金,1),标底,标底+资金,0.8,0),COLORYELLOW;
STICKLINE((标底+资金)<=标底 AND (标底+资金)<=REF(标底+资金,1),标底,标底+资金,0.8,0),COLORFF9900;
STICKLINE((标底+资金)<=标底 AND (标底+资金)>REF(标底+资金,1),标底,标底+资金,0.8,0),COLORCC66FF;
资金线:=标底+资金,DOTLINE,COLORWHITE,LINETHICK1;}

涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);
{DRAWICON(涨停,标底,24);}

{ ·········································}
TJ11:=CROSS(分水岭,操作线);
TJ12:=CROSS(PM,分水岭);
TJ13:=(操作线<=REF(操作线,1) AND REF(操作线,1)>=REF(操作线,2) AND 操作线<=分水岭);
预警点:IF(TJ11 OR TJ12 OR TJ13,标底*1.08,标底),COLORYELLOW,LINETHICK2;

界:分水岭,COLORWHITE,LINETHICK2;
操作:操作线,COLORGREEN,LINETHICK2;
标底线:标底,COLORGREEN,LINETHICK2;

IF(操作线<=REF(操作线,1) AND 操作线<=分水岭,操作线,DRAWNULL),POINTDOT,COLORWHITE,LINETHICK9;
IF(操作线<=REF(操作线,1) AND 操作线<=分水岭,操作线,DRAWNULL),POINTDOT,COLORRED,LINETHICK5;

{ ·········································}
DRAWRECTREL(0,100,260,400,RGB(18,8,8));
DRAWTEXT_FIX(1,0.01,0.01,0,HYBLOCK),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR AND 买增 AND 卖减,0.17,0.12,1,'★'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND Q上,0.17,0.2,1,'Q↑'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND Q下,0.17,0.2,1,'Q↓'),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR AND 量增,0.17,0.28,1,'量↑'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND 量减,0.17,0.28,1,'量↓'),COLORGREEN;

DRAWTEXT_FIX(ISLASTBAR AND 买增 AND 卖减 AND 买盘>卖盘,0.999,0.1,1,'★'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND 买增 AND 卖减 AND 买盘>卖盘,0.999,0.2,1,'★'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR AND 买增 AND 卖减 AND 买盘>卖盘,0.999,0.3,1,'★'),COLORYELLOW;

流通股本:=FINANCE(7)/100000000;
DRAWTEXT_FIX(ISLASTBAR,0.3,0.01,1,'流通股本:'),COLORWHITE;
DRAWNUMBER_FIX(ISLASTBAR,0.4,0.01,1,流通股本),COLORYELLOW;

DRAWTEXT_FIX(ISLASTBAR,0.55,0.01,1,'涨幅:'),COLORYELLOW;
DRAWNUMBER_FIX(ISLASTBAR,0.65,0.01,1,涨幅),COLORWHITE;
DRAWNUMBER_FIX(ISLASTBAR,0.75,0.01,1,昨涨幅),COLORWHITE;

DRAWNUMBER_FIX(ISLASTBAR,0.1,0.12,1,INTPART(线角)),COLORWHITE;
DRAWNUMBER_FIX(ISLASTBAR,0.1,0.2,1,INTPART(REF(Q1,1))),COLORGREEN;
DRAWNUMBER_FIX(ISLASTBAR,0.23,0.2,1,INTPART(Q1)),COLORYELLOW;
DRAWNUMBER_FIX(ISLASTBAR,0.1,0.28,1,INTPART(REF(成交量比差,1))),COLORWHITE;
DRAWNUMBER_FIX(ISLASTBAR,0.23,0.28,1,INTPART(成交量比差)),COLORYELLOW;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.12,1,INTPART(角1)),COLORYELLOW;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.2,1,INTPART(角2)),COLORYELLOW;
DRAWNUMBER_FIX(ISLASTBAR,0.05,0.28,1,INTPART(角3)),COLORYELLOW;--{ 慧眼识铢预警 }

线角:=ATAN((C/REF(C,1)-1)*100)*180/3.1416;

N1:=6;
N2:=12;
N3:=24;
乖1:=(CLOSE-MA(CLOSE,N1))/MA(CLOSE,N1)*100+100;
乖2:=(CLOSE-MA(CLOSE,N2))/MA(CLOSE,N2)*100+100;
乖3:=(CLOSE-MA(CLOSE,N3))/MA(CLOSE,N3)*100+100;
角1:=ATAN((乖1/REF(乖1,1)-1)*100)*180/3.1416;
角2:=ATAN((乖2/REF(乖2,1)-1)*100)*180/3.1416;
角3:=ATAN((乖3/REF(乖3,1)-1)*100)*180/3.1416;
乖离角:=角1>=70 AND 角2>=70 AND 角3>=70;

Q1:=-100*(HHV(H,6)-C)/(HHV(HIGH,6)-LLV(L,6))+100;
Q上:=Q1>=REF(Q1,1);
TJ01:=Q1>=70 AND Q上;

GZ:=(LOW+HIGH+CLOSE)/3;
BB:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:=IF(MA(CLOSE,17)<BB,BB,MA(CLOSE,17));
操作线:=分水岭-(EMA(C,3)-分水岭);
PM:=EMA(GZ,5);
TJ02:=操作线<=分水岭 AND 操作线<=REF(操作线,1);

TJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买盘:=IF(CLOSE>OPEN,TJ*(HIGH-LOW),IF(CLOSE<OPEN,TJ*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
卖盘:=IF(CLOSE>OPEN,TJ*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,TJ*(HIGH-LOW),VOL/2));
正成交量比%:=买盘/VOL*100;
负成交量比%:=卖盘/VOL*100;
正量比:=正成交量比%>=70 AND 正成交量比%>=REF(正成交量比%,1);
成交量比差:=(正成交量比%-负成交量比%);
量增:=成交量比差>=REF(成交量比差,1);
量减:=成交量比差<REF(成交量比差,1);
买增:=买盘>=REF(买盘,1);
卖减:=卖盘<=REF(卖盘,1);
增量:=正量比 AND (卖减 OR 卖盘=0);

B1:=ZIG(3,5)*20;
B1红:=B1>REF(B1,1);

涨幅:=(C-REF(C,1))/REF(C,1)*100;
剔跳空:=(O-REF(C,1))/REF(C,1)*100<=6;
N日均涨幅:=(REF(C,1)-REF(C,2))/REF(C,2)*100;
涨幅限:=涨幅<=7.2;

VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);
VOLUME:=VOL;
MAVOL1:=MA(VOLUME,10);

虚拟倍量:=VVOL/MAVOL1>=N;

{条件}识铢:=CROSS(分水岭,操作线) OR CROSS(PM,分水岭) OR ((操作线<=REF(操作线,1) AND REF(操作线,1)>=REF(操作线,2)) AND 操作线<=分水岭);
{条件}趋势:=线角>=70 AND 乖离角 AND TJ01 AND TJ02 AND 增量 AND B1红;
{条件}限制:=剔跳空 AND 涨幅限;

预警:COUNT(识铢,3) AND 趋势 AND 限制 AND 虚拟倍量;--预警参数:   N  设为4--谢谢楼主分享!!!!!!--多谢楼主分享!!!!!--@枯禅又来 谢谢分享--当前公式 : 慧眼识珠 (条件选股公式)  
错误句 :

虚拟倍量:=VVOL/MAVOL1>=N
详细信息 : 未知字符串 N
错误起始位置 : 1547 ; 长度: 1--谢谢分享.下了再支持。--@珍惜此生  见4楼参数--@枯禅又来  @枯禅又来 谢谢-- --行45: 缺少 ;--谢谢楼主的无私奉献--谢谢楼主热心分享,楼主辛苦了!不用也顶!投资愉快!--感谢老师分享--谢谢分享! --多谢,无惜贡献。投资顺利。--谢谢楼主分享!!!!!!--看贴回帖,谢谢分享。
 枯禅又来:   2016-3-1 08:21
   上图先

[ 本帖最后由 枯禅又来 于 2016-3-1 08:30 编辑 ]

 股票专家荐股少而精.成功率达95%免费个股咨询点这里

 想了解手头持有个股接下来的走势个股论坛-股票吧点击这里

自用狙击涨停板的主图和预警公式(贴图、源码、通达信)..更多详情请加腾飞涨停微信:gupiao139

相关热词搜索:通达信 涨停 涨停板 分时选股

上一篇:通达信MACD底背离指标
下一篇:发布一通达信刀口舔血指标,成功率还需验证

本栏点击总排行
分享到: 收藏
短信荐股回顾
邮件传真荐股回顾
整网点击月排行
整网点击排行