请老师把以下公式中的买入跟牛暴涨做一个选股公式
2014-01-15 21:16:00   来源:股票壹网   评论:0 点击:

请老师把以下公式中的买入跟牛暴涨做一个选股公式 我不是班长,希望能用上 买入 ZK1:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25); ZD1:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,2
  请老师把以下公式中的买入跟牛暴涨做一个选股公式
我不是班长,希望能用上.
买入
ZK1:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25);
ZD1:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1;
ZD2:=EMA(ZD1,25);

VAR23:=100*XMA(XMA((C-REF(C,1)),6),6)/XMA(XMA(ABS((C-REF(C,1))),6),6);
回调买:=LLV(VAR23,2)=LLV(VAR23,7) AND COUNT(VAR23<0,2) AND CROSS(VAR23,MA(VAR23,2));
XG:ZD1>HIGH AND 回调买 AND L<=ZD1;

牛爆涨
ZK1:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25);
ZD1:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1;
ZD2:=EMA(ZD1,25);

VAR23:=100*XMA(XMA((C-REF(C,1)),6),6)/XMA(XMA(ABS((C-REF(C,1))),6),6);
回调买:=LLV(VAR23,2)=LLV(VAR23,7) AND COUNT(VAR23<0,2) AND CROSS(VAR23,MA(VAR23,2));
XG:=ZD1>HIGH AND 回调买 AND L<=ZD1;

JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,10000,10000);
V2:=SMA(IF(C>=REF(C,1),DDX,-DDX/100),2,1);
V5:=SMA(V2*120/FROMOPEN*5,2,1);
V10:=SMA(V5,5,1);
V20:=SMA(V10,5,1);
DY:=CURRBARSCOUNT=1 AND C<REF(C,1);
DY2:=REF(V2,1)-DY;
XG2:=C>O AND DY2<0.02 AND MA(C,5)>MA(C,60) AND C/REF(C,1)>=1.02 AND H<ZK1;
GG: XG2 AND L<ZD1;--学习。。。。。。。。。。。--@马上有钱 该公式包含未来函数:WINNER
未发现:LWINNER...
该公式包含未来函数:COST
该公式包含未来函数:CAPITAL
未发现:DYNAINFO...
未发现:FINANCE...
该公式包含未来函数:XMA
未发现:#MONTH...--@崇福大王子 感谢老师的指导,不过有未来函数的话都 没有什么用是不是,老师你有没有什么好的指标呀,借小弟弟 用用--@东湖风   有未来函数是什么意思
 马上有钱:   2014-1-15 21:16
   DRAWGBK(C>O,RGB(60,0,0),RGB(0,0,0),1,2,1);
DRAWTEXT_FIX(1,0.88,5,0,'~☆~隆逸优化作品~☆~'),COLORRED;
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
ZK1:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),DOTLINE,COLORBLUE;
ZD1:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK2,COLORRED;
ZD2:EMA(ZD1,25),LINETHICK2;
DRAWBAND(ZD1,RGB(55,0,0),ZD2,RGB(0,91,0));
DRAWKLINE(H,O,L,C);
STICKLINE(ZD1>LOW AND ZD1<HIGH,ZD1,MIN(MIN(OPEN,CLOSE),ZD1),2,0),COLORYELLOW;
STICKLINE(ZD1>MIN(C,O) AND ZD1<MAX(C,O),ZD1,MIN(OPEN,CLOSE),2,0),COLORYELLOW;
STICKLINE(ZD1>HIGH,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(ZD1>HIGH,HIGH,LOW,0,0),COLORYELLOW;
VAR23:=100*XMA(XMA((C-REF(C,1)),6),6)/XMA(XMA(ABS((C-REF(C,1))),6),6);
回调买:=LLV(VAR23,2)=LLV(VAR23,7) AND COUNT(VAR23<0,2) AND CROSS(VAR23,MA(VAR23,2));
XG:=ZD1>HIGH AND 回调买 AND L<=ZD1;
DRAWTEXT(XG,L,'▲买入'),COLORRED;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,10000,10000),COLOR00AAAA,LINETHICK;
V2:=SMA(IF(C>=REF(C,1),DDX,-DDX/100),2,1);
V5:=SMA(V2*120/FROMOPEN*5,2,1);
V10:=SMA(V5,5,1);
V20:=SMA(V10,5,1);
DY:=CURRBARSCOUNT=1 AND C<REF(C,1);
DY2:=REF(V2,1)-DY;
XG2:=C>O AND DY2<0.02 AND MA(C,5)>MA(C,60) AND C/REF(C,1)>=1.02 AND H<ZK1;
{DRAWTEXT(XG2,L,'▲抓牛'),COLORYELLOW;}
DRAWTEXT(XG2 AND L<ZD1,L,'↖牛暴涨'),COLORRED;
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=-L2_AMO(0,3)/10000.0;
大S:=-L2_AMO(1,3)/10000.0;
中S:=-L2_AMO(2,3)/10000.0;
小S:=-L2_AMO(3,3)/10000.0;
TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);
净流入:=(超B+大B+中B+小B)+(超S+大S+中S+小S);
大宗净流入:=(超B+大B)+(超S+大S);
超大单:=(超B)+(超S);
大单:=(大B)+(大S);
中单:=(中B)+(中S);
小单:=(小B)+(小S);
大宗进:=(超B)+(大B);
大宗出:=(超S)+(大S);
非大宗进:=(中B)+(小B);
非大宗出:=(中S)+(小S);
资金流向:=(超B+大B+中B+小B)+(超S+大S+中S+小S);
近5日流向:=SUM(资金流向,5);
近10日流向:=SUM(资金流向,10);
主力资金线:=(L2_AMO(0,0)+L2_AMO(1,0)-L2_AMO(0,1)-L2_AMO(1,1))/100.0,LINETHICK2;
主力买力度:=LARGEINTRDVOL*100/VOL;
主力卖力度:=LARGEOUTTRDVOL*100/VOL;
AAB:=CONST(MAX(ABS(超大单),MAX(ABS(大单),MAX(ABS(中单),ABS(小单))))),NODRAW;
DRAWRECTREL(5,CONST(830-(ABS(超大单)*500/AAB))/2,35,460,IF(CONST(超大单)>0,RGB(255,0,255),RGB(0,255,255)));
DRAWRECTREL(40,CONST(830-(ABS(大单)*500/AAB))/2,70,460,IF(CONST(大单)>0,RGB(255,0,255),RGB(0,255,255)));
DRAWRECTREL(75,CONST(830-(ABS(中单)*500/AAB))/2,105,460,IF(CONST(中单)>0,RGB(255,0,255),RGB(0,255,255)));
DRAWRECTREL(110,CONST(830-(ABS(小单)*500/AAB))/2,140,460,IF(CONST(小单)>0,RGB(255,0,255),RGB(0,255,255)));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.007,0.46,0,'超 户 大 户 中 户 散 户'),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.007,0.4,0,INTPART(超大单)),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.042,0.4,0,INTPART(大单)),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.076,0.4,0,INTPART(中单)),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.112,0.4,0,INTPART(小单)),COLORWHITE;
TYX3:=MA(REF(HHV((C+L+O+H)/4,30),1),3);
筹码突破:=C>TYX3 AND(C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),COLORRED;
A111:=COST(85);
A222:=COST(15);
A333:=A111-A222;
A444:=(A111+A222)/2;
单峰密集:=A333/A444*100<30,LINETHICK0;
{A5:=A3/A4*100<30;}
B1:=HHV(HIGH,250);
B2:=LLV(LOW,250);
B3:=B1-B2;
B4:=(A444-B2);
低位:=A444<(B3*04+B2),LINETHICK0;
低位单峰密集:=单峰密集 AND 低位;
B5:=C/REF(C,1)>1.04; {AND V/REF(V,1)>2;{ AND H=C;}
主力持仓%:=EMA(100*(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30)),3);
主力持仓大于75%:=主力持仓%>=75 {AND 主力持仓%<=91} AND C>0 AND CLOSE>OPEN AND C=H;
敢死吗:=主力持仓大于75% AND 低位单峰密集 AND B4 AND WINNER(C)>=0.91 AND B5,COLORGREEN,LINETHICK3;
{DRAWTEXT(FILTER(敢死吗=1,5),L,'----敢死吗'),COLORGREEN;}
DRAWICON(FILTER(敢死吗=1,5),L*0.995,25);
DIF1:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA1:=EMA(DIF1,9);
AAA1:=(DIF1-DEA1)*2*60;
AAA上:=IF(AAA1>REF(AAA1,1),AAA1,DRAWNULL);
AAA下:=IF(AAA1<REF(AAA1,1),AAA1,DRAWNULL);
买:=13;
入:=AAA1-REF(AAA1,1);
正大:=CROSS(入,买);
DIF2:=EMA(DCLOSE,10)-EMA(DCLOSE,72);
DEA2:=EMA(DIF2,17);
AAA:=(DIF2-DEA2)*2*60;
入2:=AAA-REF(AAA,1);
牛股:=CROSS(入2,13);
正大牛股:=正大 AND 牛股;
DRAWICON(正大牛股,L*0.99,1);
VAR1:=(CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*100;
VAR2:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR3:=SMA(VAR2,3,1);
天:=100+(-ABS(VAR1)),COLORRED;
下:=SMA(VAR3,2,1);
无:=ABS(VAR1),COLORGREEN;
敌:=50,COLORFFAA00,LINETHICK3;
DRAWTEXT(CROSS(无,10) AND C>O,L,'<---天下无敌'),COLORGREEN;
LC:=REF(CLOSE,1);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
卖:=CROSS(90,操作线);
DRAWICON(卖,H*1.01,8);
绝底线:=5;
买阴线1:操作线<5 AND ZD1>ZD2 AND L<ZD1;
DRAWICON(买阴线1,L*0.98,7);
买阴线2:操作线<5 AND ZD1<ZD2 AND L<ZD1;
DRAWICON(买阴线2,L*0.995,7);

[ 本帖最后由 福阿德 于 2014-1-15 21:58 编辑 ]

 股票专家荐股少而精.成功率达95%免费个股咨询点这里
请老师把以下公式中的买入跟牛暴涨做一个选股公式..更多详情请加腾飞涨停微信:gupiao163 或 18692083657 股票壹专家指导服务微信

相关热词搜索:通达信 指标编写互助答疑区

上一篇:如何让主图在K线前面的筹码指标到后面
下一篇:请老师帮忙写个(选出V1到10的)预公式(谢谢冷妞,已解决!)

本栏点击总排行
分享到: 收藏
短信荐股回顾
邮件传真荐股回顾
整网点击月排行
整网点击排行