这个DMI副图公式,给我一份吧都等1年半了,(源码)
2010-02-07 12:05:00   来源:股票壹网   评论:0 点击:

这个DMI副图公式,给我一份吧都等1年半了,(源码) 谢谢分享 新年快乐--谢谢提供原码分享--谢谢分享 新年快乐--e有没有大智慧L2的--谢谢提供原码分享
  这个DMI副图公式,给我一份吧都等1年半了,(源码)
谢谢分享
新年快乐--谢谢提供原码分享--谢谢分享
新年快乐--e有没有大智慧L2的--谢谢提供原码分享.................................................................................................--谢谢楼主分享--谢谢楼主分享!!!!--周末愉快...........--谢谢分享!!!!!!!!!!!!!!!--感谢分享,有没有通达信的版本--谢谢提供原码分享!!!--
引用:
原帖由 颁布 于 2010-2-7 12:05 发表
这个DMI副图公式,给我一份吧都等1年半了
{DMIA}
ATRA := SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),6,1);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SMA(IF(HD>0 AND  ...     
谢谢提供!!! --周末愉快...........--谢谢提供原码分享--谢谢提供原码分享

谢谢提供原码分享

谢谢提供原码分享

谢谢提供原码分享

谢谢提供原码分享

谢谢提供原码分享

谢谢提供原码分享

谢谢提供原码分享

谢谢提供原码分享

谢谢提供原码分享

谢谢提供原码分享--谢谢提供原码分享--谢谢提供原码分享...--周末愉快。小年到了。。。--谢谢提供原码分享
 颁布:   2010-2-7 12:05
   这个DMI副图公式,给我一份吧都等1年半了
{DMIA}
ATRA := SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),6,1);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
DMP:= SMA(IF(HD>0 AND HD>LD,HD,0),6,1);
DMM:= SMA(IF(LD>0 AND LD>HD,LD,0),6,1);
PDI:= DMP*100/ATRA;
MDI:= DMM*100/ATRA;
ADX: SMA(ABS(MDI-PDI)/(MDI+PDI)*100,6,1),LINETHICK2;
涨趋势:FILLRGN((MDI-PDI)/(MDI+PDI)<0,10,ADX),COLOR8899DD;
跌趋势:FILLRGN((MDI-PDI)/(MDI+PDI)>=0,10,ADX),COLORDD9988;
对比线:=(ADX+REF(ADX,6))/2;
STICKLINE(交叉函数(ADX,30),ADX,30,10,0),Color00FFFF,LINETHICK5;
80,ColorFFFFFF,LINEDOT;
50,LINEDOT;
20,LINEDOT;
ww1:=SMA(((CLOSE-LLV(CLOSE,10))/(HHV(HIGH,10)-LLV(LOW,10))),3,1);
ww2:=SMA(((ww1-LLV(ww1,3))/(HHV(ww1,3)-LLV(ww1,3))),3,1)*100;
zz:=SMA(((VOL-LLV(VOL,10))/(HHV(VOL,10)-LLV(VOL,10))),3,1);
zz1:=SMA(((zz-LLV(zz,3))/(HHV(zz,3)-LLV(zz,3))),3,1)*100;
快线:=EMA(ww2,1),COLORBLUE,LINETHICK2;
慢线:=EMA(快线,2),COLORGREEN,LINETHICK2;
量快:=EMA(zz1,1)COLORWHITE,LINETHICK2;
量慢:=EMA(量快,2),COLORWHITE,LINETHICK2;
AA1:=移动平均(((收盘价-最低值(收盘价,13))/(最高值(最高价,13)-最低值(最低价,13))),3,1);
价线:=移动平均(((AA1-最低值(AA1,4))/(最高值(AA1,4)-最低值(AA1,4))),3,1)*100;
周线:MA(价线,5),COLORMAGENTA,LINETHICK0;
BB1:=移动平均(((vol-最低值(vol,13))/(最高值(vol,13)-最低值(vol,13))),3,1);
量线:=移动平均(((BB1-最低值(BB1,4))/(最高值(BB1,4)-最低值(BB1,4))),3,1)*100;
周量:MA(量线,5),COLORyellow,LINETHICK0;
月线:=MA(价线,22),COLORRED,LINEDOT,LINETHICK0;
月量:=MA(量线,22),COLORyellow,LINEDOT,LINETHICK0;

快线2:=EMA(周线,1),COLORBLUE,LINETHICK2;
慢线2:=EMA(快线2,2),COLORGREEN,LINETHICK2;
量快2:=EMA(周量,1)LINEDOT;
量慢2:=EMA(量快2,2),COLORWHITE,LINETHICK2;
DRAWICON(CROSS(快线2,慢线2),慢线2,10);
DRAWICON(CROSS(慢线2,快线2),快线2,11);
DRAWICON(CROSS(量快2,量慢2),量慢2,10);
DRAWICON(CROSS(量慢2,量快2),量快2,11);

PARTLINE(周线>=REF(周线,1),周线),COLORMAGENTA,LINEDOT,LINETHICK2;
PARTLINE(周线>=REF(周线,1) AND 月线>=REF(月线,1),周线),COLORRED,LINEDOT,LINETHICK2;
PARTLINE(周线<REF(周线,1),周线),COLORgreen,LINEDOT,LINETHICK1;
PARTLINE(周量>=REF(周量,1),周量),COLORyellow,LINEDOT,LINETHICK2;
PARTLINE(周量<REF(周量,1),周量),COLORgreen,LINEDOT,LINETHICK1;
DRAWTEXT(FILTER(快线>=95 AND 慢线>=95 AND  周线>=90  OR 周量>=90,5),85,"减'),COLORWHITE,LINETHICK2;
看色块→:FILLRGN(1,30,31),COLORRED;

 股票专家荐股少而精.成功率达95%免费个股咨询点这里

 想了解手头持有个股接下来的走势个股论坛-股票吧点击这里
这个DMI副图公式,给我一份吧都等1年半了,(源码)..更多详情请加腾飞涨停微信:gupiao161 或 17067888011 股票壹专家指导服务微信

相关热词搜索:飞 狐 指标公式分享交流区

上一篇:同花顺的所有副图都可以改主图,具体方法
下一篇:超精准指标

本栏点击总排行
分享到: 收藏
短信荐股回顾
邮件传真荐股回顾
整网点击月排行
整网点击排行